mariadb: fix libmariadb depends
authorSebastian Kemper <sebastian_ml@gmx.net>
Mon, 11 Feb 2019 20:44:36 +0000 (21:44 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Mon, 11 Feb 2019 20:44:42 +0000 (21:44 +0100)
The shared library does not depend on libatomic nor libstdcpp anymore.
This is very good news for the users of said lib.

This commit updates the depends accordingly.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
utils/mariadb/Makefile

index 6a987d1c07f3b6f7e0b8bdd67b63bbc85a81adf7..89d92fa55f6c0c95ada612f7292886215b58c7c3 100644 (file)
@@ -171,11 +171,14 @@ include $(INCLUDE_DIR)/nls.mk
 
 MARIADB_COMMON_DEPENDS := \
        $(ICONV_DEPENDS) \
-       +libatomic \
        +libopenssl \
-       +libstdcpp \
        +zlib
 
+MARIADB_COMMON_DEPENDS_EXE := \
+       $(MARIADB_COMMON_DEPENDS) \
+       +libatomic \
+       +libstdcpp
+
 # Pass CPPFLAGS in the CFLAGS as otherwise the build system will
 # ignore them.
 TARGET_CFLAGS+=$(TARGET_CPPFLAGS)
@@ -256,7 +259,7 @@ define Package/mariadb-client-base
   $(call Package/mariadb/Default)
   TITLE:=MariaDB database client base
   DEPENDS:=mariadb-common \
-         $(MARIADB_COMMON_DEPENDS) \
+         $(MARIADB_COMMON_DEPENDS_EXE) \
          +libedit
 endef
 
@@ -324,7 +327,7 @@ endef
 define Package/mariadb-server-base
   $(call Package/mariadb/Default)
   DEPENDS:=mariadb-common \
-         $(MARIADB_COMMON_DEPENDS) \
+         $(MARIADB_COMMON_DEPENDS_EXE) \
          +!arc:libaio \
          +liblzma \
          +libpcre \