libshout: Fix OpenSSL 1.1.0 without deprecated APIs
authorRosen Penev <rosenp@gmail.com>
Tue, 29 May 2018 04:14:34 +0000 (21:14 -0700)
committerRosen Penev <rosenp@gmail.com>
Wed, 30 May 2018 01:31:20 +0000 (18:31 -0700)
Previous patch was incomplete and broke with deprecated APIs
disabled.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libshout/Makefile
libs/libshout/patches/150-openssl-1.1.patch

index 83d52748581994b99d517a9c43f4697547ef9cff..101f3c0dbfcd87298d9b808dd2c5159a63180025 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libshout
 PKG_VERSION:=2.4.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index 77ee832943eae430bff116a6a95dd95241c31520..6028919ca6f660282bafb0d062c15b799bbbd32a 100644 (file)
@@ -1,6 +1,8 @@
+diff --git a/src/tls.c b/src/tls.c
+index 4562c73..f946946 100644
 --- a/src/tls.c
 +++ b/src/tls.c
-@@ -63,10 +63,12 @@ static inline int tls_setup(shout_tls_t
+@@ -63,12 +63,16 @@ static inline int tls_setup(shout_tls_t *tls)
  {
        SSL_METHOD *meth;
  
@@ -9,7 +11,11 @@
        SSL_load_error_strings();
        SSLeay_add_all_algorithms();
        SSLeay_add_ssl_algorithms();
-+#endif
  
        meth = TLSv1_client_method();
++#else
++      meth = TLS_client_method();
++#endif
        if (!meth)
+               goto error;