opencv: Update to 4.1.2
authorRosen Penev <rosenp@gmail.com>
Sun, 8 Dec 2019 23:07:58 +0000 (15:07 -0800)
committerRosen Penev <rosenp@gmail.com>
Sun, 8 Dec 2019 23:08:32 +0000 (15:08 -0800)
Removed upstreamed patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/opencv/Makefile
libs/opencv/patches/010-uclibc-ng.patch [deleted file]
libs/opencv/patches/020-l_tmpnam.patch [deleted file]

index f2690b5e32c9b017eb44d9564f7d11aaf82c3239..e7267e1d09d2f4343df7b7f4fffbdceab738e38d 100644 (file)
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opencv
-PKG_VERSION:=4.1.1
-PKG_RELEASE:=2
+PKG_VERSION:=4.1.2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/opencv/opencv
 PKG_SOURCE_VERSION:=$(PKG_VERSION)
-PKG_MIRROR_HASH:=c8587820421d2f22acdafe4712d068ae490897dc445bdb4aa128ecaa8e65d3a1
+PKG_MIRROR_HASH:=1bd1cad4fa5c8f21499a45869fea40b7886026c048129a01be87b092178258c1
 
 PKG_MAINTAINER:=
 PKG_LICENSE:=BSD-3-Clause
diff --git a/libs/opencv/patches/010-uclibc-ng.patch b/libs/opencv/patches/010-uclibc-ng.patch
deleted file mode 100644 (file)
index 52e9fd0..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
---- a/modules/gapi/include/opencv2/gapi/core.hpp
-+++ b/modules/gapi/include/opencv2/gapi/core.hpp
-@@ -392,8 +392,8 @@ namespace core {
-             {
-                 GAPI_Assert(fx != 0. && fy != 0.);
-                 return in.withSize
--                    (Size(static_cast<int>(std::round(in.size.width  * fx)),
--                          static_cast<int>(std::round(in.size.height * fy))));
-+                    (Size(static_cast<int>(round(in.size.width  * fx)),
-+                          static_cast<int>(round(in.size.height * fy))));
-             }
-         }
-     };
---- a/modules/gapi/include/opencv2/gapi/own/saturate.hpp
-+++ b/modules/gapi/include/opencv2/gapi/own/saturate.hpp
-@@ -81,8 +81,8 @@ static inline DST saturate(SRC x, R round)
- // explicit suffix 'd' for double type
- inline double  ceild(double x) { return std::ceil(x); }
- inline double floord(double x) { return std::floor(x); }
--inline double roundd(double x) { return std::round(x); }
--inline double  rintd(double x) { return std::rint(x); }
-+inline double roundd(double x) { return round(x); }
-+inline double  rintd(double x) { return rint(x); }
- } //namespace own
- } //namespace gapi
---- a/modules/gapi/src/backends/fluid/gfluidcore.cpp
-+++ b/modules/gapi/src/backends/fluid/gfluidcore.cpp
-@@ -389,7 +389,7 @@ static void run_arithm_s1(uchar out[], const float in[], int width, const float
-     cv::util::suppress_unused_warning(v_op);
-     for (; w < width; w++)
-     {
--        out[w] = saturate<uchar>(s_op(in[w], scalar[0]), std::roundf);
-+        out[w] = saturate<uchar>(s_op(in[w], scalar[0]), roundf);
-     }
- }
-@@ -1954,7 +1954,7 @@ GAPI_FLUID_KERNEL(GFluidCartToPolar, cv::gapi::core::GCartToPolar, false)
-         {
-             float x = in1[l];
-             float y = in2[l];
--            float magnitude = std::hypot(y, x);
-+            float magnitude = hypot(y, x);
-             float angle_rad = std::atan2(y, x);
-             float angle = angleInDegrees?
-                           angle_rad * static_cast<float>(180 / CV_PI):
diff --git a/libs/opencv/patches/020-l_tmpnam.patch b/libs/opencv/patches/020-l_tmpnam.patch
deleted file mode 100644 (file)
index 31a2bc2..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/3rdparty/libjasper/jas_stream.c
-+++ b/3rdparty/libjasper/jas_stream.c
-@@ -86,6 +86,10 @@
- #include <io.h>
- #endif
-+#ifndef L_tmpnam
-+#define L_tmpnam 20
-+#endif
-+
- #include "jasper/jas_types.h"
- #include "jasper/jas_stream.h"
- #include "jasper/jas_malloc.h"