cloudreve: Update to 3.5.1
authorTianling Shen <cnsztl@immortalwrt.org>
Mon, 18 Apr 2022 19:27:36 +0000 (03:27 +0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 25 Apr 2022 19:14:32 +0000 (12:14 -0700)
Removed statik which was deprecated by the project.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
net/cloudreve/Makefile

index b8345f83b030bf929fc6e6aed905e58e9583fec4..0f4dedbb9545e0e84dcfb46361d2935600fcc706 100644 (file)
@@ -5,19 +5,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cloudreve
-PKG_VERSION:=3.4.2
+PKG_VERSION:=3.5.1
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/cloudreve/Cloudreve.git
 PKG_SOURCE_VERSION:=$(PKG_VERSION)
-PKG_MIRROR_HASH:=7ceda70ae80582df46e0f110ad5d21c825aadcd75441be3e39c714e0c7d3ba19
+PKG_MIRROR_HASH:=d9892bf18c4e6af65d233d1263d873e94baf6ab55fa25438457800ae2e418642
 
 PKG_LICENSE:=GPL-3.0-only
 PKG_LICENSE_FILES:=LICENSE
 PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
 
-PKG_BUILD_DEPENDS:=golang/host node/host node-yarn/host statik/host
+PKG_BUILD_DEPENDS:=golang/host node/host node-yarn/host
 PKG_BUILD_PARALLEL:=1
 PKG_USE_MIPS16:=0
 
@@ -45,12 +45,9 @@ endef
 
 define Build/Compile
        ( \
-               pushd $(PKG_BUILD_DIR) ; \
-               cd assets ; \
+               pushd $(PKG_BUILD_DIR)/assets ; \
                yarn install ; \
                yarn run build ; \
-               cd ../ ; \
-               statik -src=assets/build/  -include=*.html,*.js,*.json,*.css,*.png,*.svg,*.ico -f ; \
                popd ; \
                $(call GoPackage/Build/Compile) ; \
        )