glib2: install codegen module in staging dir
authorAleksander Morgado <aleksander@aleksander.es>
Thu, 30 Jul 2020 07:29:24 +0000 (09:29 +0200)
committerAleksander Morgado <aleksander@aleksander.es>
Thu, 30 Jul 2020 07:32:05 +0000 (09:32 +0200)
Install not only the gdbus-codegen program in the target staging dir,
but also the actual codegen module, so that the program is fully
usable by other packages that require it during build.

Signed-off-by: Aleksander Morgado <aleksander@aleksander.es>
libs/glib2/Makefile

index df6c5c329f82abccdebfbad8a75e4d5db9e0d7e5..522d02a710292c7fcc7f7183b4f21329067b2358 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glib2
 PKG_VERSION:=2.65.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNOME/glib/2.65
@@ -116,6 +116,11 @@ define Build/InstallDev
        $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/share/aclocal/*.m4  \
                $(2)/share/aclocal/
+
+       $(INSTALL_DIR) $(1)/usr/share/glib-2.0
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/share/glib-2.0/codegen \
+               $(1)/usr/share/glib-2.0/
 endef
 
 define Package/glib2/install