realtek: HPE 1920 8G PoE+ 180W move fans to hwmon
authorEvan Jobling <evan@jobling.au>
Tue, 14 Jan 2025 12:13:21 +0000 (12:13 +0000)
committerSander Vanheule <sander@svanheule.net>
Wed, 15 Jan 2025 07:21:08 +0000 (08:21 +0100)
The GPIO numbering has changed and is not stable. As a result fan
control via gpio_switch is broken, resulting in errors:
    "export_store: invalid GPIO 456"

Move to using hwmon and gpio-fan. This is by adding gpio_fan_array to
DTS and kmod-hwmon-gpiofan to DEVICE_PACKAGES.

In combination with the new rtl8231 gpio driver the default fan
behaviour will be maximum fan speed.

Bump compat value to 1.1 due to existing config in /etc/config/system
via gpio_switch. Also notify in device compat that fan is now going to
be at bootloader setting (maximum in this case) by default unless turned
down.

Signed-off-by: Evan Jobling <evan@jobling.au>
Link: https://github.com/openwrt/openwrt/pull/17605
Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/realtek/base-files/etc/board.d/03_gpio_switches
target/linux/realtek/base-files/etc/board.d/05_compat-version
target/linux/realtek/dts/rtl8380_hpe_1920-8g-poe-180w.dts
target/linux/realtek/image/common.mk
target/linux/realtek/image/rtl838x.mk

index c869153e4ca4072b6b119773667e664254a7429c..c178bd43308fc1338a41bc76c9a768e70287767a 100644 (file)
@@ -6,7 +6,6 @@ board_config_update
 board=$(board_name)
 
 case "$board" in
-hpe,1920-8g-poe-180w|\
 hpe,1920-24g-poe-180w|\
 hpe,1920-24g-poe-370w)
        ucidef_add_gpio_switch "fan_ctrl" "Fan control" "456" "0"
index 5c4ecb9aae363d4e431eb8aa82cf7b0be4c7e2ef..687cbb32a5ae3dc68a659f190216324e31713885 100644 (file)
@@ -8,6 +8,9 @@
 board_config_update
 
 case "$(board_name)" in
+       hpe,1920-8g-poe-180w)
+               ucidef_set_compat_version "1.1"
+       ;;
        zyxel,gs1900-8 | \
        zyxel,gs1900-8hp-v1 | \
        zyxel,gs1900-8hp-v2 | \
index 6398e6d034dee3e2ddc335d9d06ddb0ad271b2ad..f15498354e9ae04f3db5020114628158c08802be 100644 (file)
@@ -5,6 +5,17 @@
 / {
        compatible = "hpe,1920-8g-poe-180w", "realtek,rtl838x-soc";
        model = "HPE 1920-8G-PoE+ 180W (JG922A)";
+
+       gpio_fan_array {
+               compatible = "gpio-fan";
+
+               gpios = <&gpio1 5 GPIO_ACTIVE_HIGH>;
+               gpio-fan,speed-map =    <5000 0>,
+                                       <8200 1>;
+
+               alarm-gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
+               #cooling-cells = <2>;
+       };
 };
 
 &uart1 {
index d9647dbc07288efaf50cfcdc7ab642c39dc62615..e600b2347d71fc4ec6eba6aa1ca60ffc78c2afa7 100644 (file)
@@ -56,6 +56,14 @@ define Device/hpe_1920
        append-metadata
 endef
 
+define Device/hwmon-fan-migration
+  DEVICE_COMPAT_VERSION := 1.1
+  DEVICE_COMPAT_MESSAGE := Fan control switched to hwmon. Your fans will retain \
+       bootloader speed unless another control scheme is in place. \
+       Config cannot be kept due to conflict in gpio_switch config 'fan_ctrl' under \
+       /etc/config/system.
+endef
+
 define Device/zyxel_gs1900
   DEVICE_COMPAT_VERSION := 2.0
   DEVICE_COMPAT_MESSAGE := Dual firmware paritition merged due to size constraints. \
index 866659ad141210274f18a384eed4447befaecab4..27dbc6ce59a38bc3b83b1cd544f046964869fd5a 100644 (file)
@@ -120,9 +120,10 @@ TARGET_DEVICES += hpe_1920-8g-poe-65w
 
 define Device/hpe_1920-8g-poe-180w
   $(Device/hpe_1920)
+  $(Device/hwmon-fan-migration)
   SOC := rtl8380
   DEVICE_MODEL := 1920-8G-PoE+ 180W (JG922A)
-  DEVICE_PACKAGES += realtek-poe
+  DEVICE_PACKAGES += realtek-poe kmod-hwmon-gpiofan
   H3C_DEVICE_ID := 0x00010025
   SUPPORTED_DEVICES += hpe_1920-8g-poe
 endef