hplip: update to 3.23.12
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>
Sun, 16 Jun 2024 04:51:58 +0000 (01:51 -0300)
committerRosen Penev <rosenp@gmail.com>
Sun, 16 Jun 2024 23:42:03 +0000 (16:42 -0700)
See: https://developers.hp.com/hp-linux-imaging-and-printing/release_notes

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
utils/hplip/Makefile
utils/hplip/patches/010-libusb_fix.patch
utils/hplip/patches/030-replace_unsafe_memcpy_with_memmove.patch
utils/hplip/patches/070-respect-cflags.patch

index e0a36fe3e634e983298c74802b10a0f82014e786..25ea6edfd5824f723416c422fcff05cab42dcc19 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hplip
-PKG_VERSION:=3.21.6
-PKG_RELEASE:=2
+PKG_VERSION:=3.23.12
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/hplip
-PKG_HASH:=cc3360d3d913684fb080db97a434b04be45e2cef23cc5bc4cbc5f64b0c5e7bca
+PKG_HASH:=a76c2ac8deb31ddb5f0da31398d25ac57440928a0692dcb060a48daa718e69ed
 
 PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
 PKG_LICENSE:=GPL-2.0 GPL-2.0-or-later
index bcc7905d46ffd6536f489e68e7c6544f1c6fa806..5fad9a0bb9ab1f0dd397e5c8cf4d887be8b19c66 100644 (file)
@@ -9,7 +9,7 @@
  libhpmud_la_LDFLAGS += -lusb-1.0
  endif
  
-@@ -363,7 +363,7 @@ hpmudext_la_CFLAGS += -Iprotocol/discove
+@@ -365,7 +365,7 @@ hpmudext_la_CFLAGS += -Iprotocol/discove
  endif
  
  if !LIBUSB01_BUILD
index 2babb2b67a85b9768e2d7ea9538086c1865e5045..5b12986fcf03c677107f8d4f357404bb472c21d2 100644 (file)
@@ -4,7 +4,7 @@ memcpy should never be used with overlapping memory regions
 
 --- a/io/hpmud/musb.c
 +++ b/io/hpmud/musb.c
-@@ -775,7 +775,7 @@ static int device_id(int fd, unsigned ch
+@@ -776,7 +776,7 @@ static int device_id(int fd, unsigned ch
          len = size-1;   /* leave byte for zero termination */
      if (len > 2)
          len -= 2;
index c1f7c7957cf8324b23cb07a5aaa862e2cf40ec82..6853cb878aa4cbfe8dbbf144c91ffb6539d87074 100644 (file)
@@ -18,7 +18,7 @@
     then
     echo $FLAGS
     fi
-@@ -659,7 +659,7 @@ if test "$class_driver" = "no" && test "
+@@ -668,7 +668,7 @@ if test "$class_driver" = "no" && test "
     AS_IF([test "x$FOUND_HEADER" != "xyes"],
            [AC_MSG_ERROR([cannot find python-devel support], 6)])
  fi