projects
/
feed
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e63960f
)
mariadb: fix CPPFLAGS handling
author
Sebastian Kemper
<sebastian_ml@gmx.net>
Sun, 8 Jul 2018 07:54:28 +0000
(09:54 +0200)
committer
Sebastian Kemper
<sebastian_ml@gmx.net>
Sun, 8 Jul 2018 07:54:35 +0000
(09:54 +0200)
The mariadb build system ignores CPPFLAGS. Add them to CFLAGS as a
workaround.
Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
utils/mariadb/Makefile
patch
|
blob
|
history
diff --git
a/utils/mariadb/Makefile
b/utils/mariadb/Makefile
index 439ec941f3f44a38ac9870c4306784e039dac45c..e32c20b43b7558b22c7a060e47ad1196f95a6624 100644
(file)
--- a/
utils/mariadb/Makefile
+++ b/
utils/mariadb/Makefile
@@
-174,6
+174,10
@@
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
+# Pass CPPFLAGS in the CFLAGS as otherwise the build system will
+# ignore them.
+TARGET_CFLAGS+=$(TARGET_CPPFLAGS)
+
define Package/mariadb/install/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(2) $(1)/usr/bin
endef