nut: install development files for libupsclient
authorGabor Juhos <juhosg@openwrt.org>
Fri, 21 Dec 2012 18:25:35 +0000 (18:25 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 21 Dec 2012 18:25:35 +0000 (18:25 +0000)
Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34829

utils/nut/Makefile

index 9d9ffd1df567d514e4e254ff4ed5d7415cd0f8ee..3fcfb7eaba283844ec1682185328880367e2656e 100644 (file)
@@ -75,6 +75,14 @@ define Package/nut/install
        ln -sf /var/run/ups.conf $(1)/etc/nut/ups.conf
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(1)/usr/lib
+endef
+
 define Package/nut/conffiles
 /etc/nut/nut.conf
 endef
@@ -282,7 +290,8 @@ CONFIGURE_ARGS += \
   --with-group=root \
   --with-usb \
   --with-snmp \
-  --without-libltdl
+  --without-libltdl \
+  --with-dev
 
 
 $(eval $(call BuildPackage,nut))