ipq40xx: add Aruba AP-365 specific BDF
authorDavid Bauer <mail@david-bauer.net>
Wed, 25 May 2022 20:07:10 +0000 (22:07 +0200)
committerDavid Bauer <mail@david-bauer.net>
Thu, 2 Jun 2022 15:01:22 +0000 (17:01 +0200)
Aruba deploys a BDF in the root filesystem, however this matches the one
used for the DK04 reference board.

The board-specific BDFs are built into the kernel. The AP-365 shows
sinificant degraded performance with increased range when used with the
reference BDF.

Replace the BDF with the one extracted from Arubas kernel.

Signed-off-by: David Bauer <mail@david-bauer.net>
(cherry picked from commit b21b98627dcd6c1868d13964f6d84e8d43ae9ef7)

package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-aruba_ap-365.qca4019 [new file with mode: 0644]
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
target/linux/ipq40xx/image/generic.mk

index ee5d89bb3537ae2064f6c06b8ec9083f2383cc25..d3a3e319f9edbaa8e84cd3231b04e161913908e4 100644 (file)
@@ -27,6 +27,7 @@ endef
 ALLWIFIBOARDS:= \
        8dev_habanero-dvk \
        aruba_ap-303 \
+       aruba_ap-365 \
        asus_rt-ac42u \
        avm_fritzrepeater-1200 \
        buffalo_wtr-m2133hp \
@@ -120,6 +121,7 @@ endef
 
 $(eval $(call generate-ipq-wifi-package,8dev_habanero-dvk,8devices Habanero DVK))
 $(eval $(call generate-ipq-wifi-package,aruba_ap-303,Aruba AP-303))
+$(eval $(call generate-ipq-wifi-package,aruba_ap-365,Aruba AP-365))
 $(eval $(call generate-ipq-wifi-package,asus_rt-ac42u,ASUS RT-AC42U))
 $(eval $(call generate-ipq-wifi-package,avm_fritzrepeater-1200,AVM FRITZRepeater 1200))
 $(eval $(call generate-ipq-wifi-package,buffalo_wtr-m2133hp,Buffalo WTR-M2133HP))
diff --git a/package/firmware/ipq-wifi/board-aruba_ap-365.qca4019 b/package/firmware/ipq-wifi/board-aruba_ap-365.qca4019
new file mode 100644 (file)
index 0000000..7fc44a6
Binary files /dev/null and b/package/firmware/ipq-wifi/board-aruba_ap-365.qca4019 differ
index d3cc73f388e380ebd5b0704c5c98d1eb6ccab918..1f7b37d56d6dc4eb21c2650a1da632232a5778f5 100644 (file)
                };
        };
 };
+
+&wifi0 {
+       qcom,ath10k-calibration-variant = "Aruba-AP-365";
+};
+
+&wifi1 {
+       qcom,ath10k-calibration-variant = "Aruba-AP-365";
+};
+
index 5eac14e0aedcd8fc7f7fcbe274fcdcae8df04a2b..0112e18ac0be0ef8309c062138234c669619d8eb 100644 (file)
@@ -187,7 +187,7 @@ TARGET_DEVICES += aruba_ap-303h
 define Device/aruba_ap-365
        $(call Device/aruba_glenmorangie)
        DEVICE_MODEL := AP-365
-       DEVICE_PACKAGES += kmod-hwmon-ad7418
+       DEVICE_PACKAGES := kmod-hwmon-ad7418 ipq-wifi-aruba_ap-365
 endef
 TARGET_DEVICES += aruba_ap-365