usbip: Switch usb.ids location to match usbutils
authorRosen Penev <rosenp@gmail.com>
Sun, 16 Dec 2018 06:38:49 +0000 (22:38 -0800)
committerNuno Goncalves <nunojpg@gmail.com>
Thu, 24 Jan 2019 18:07:46 +0000 (19:07 +0100)
It's versioned and therefore easier to update.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/usbip/Makefile

index 11a242dab25b2e6325b826f51a0f293d5b9b2609..a2046ae00ba57e99a6f5cdc6034cee1d7c8002e0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=usbip
-PKG_RELEASE:=10
+PKG_RELEASE:=11
 PKG_LICENSE:=GPL-2.0
 
 # Since kernel 2.6.39.1 userspace tools are inside the kernel tree
@@ -81,20 +81,20 @@ endef
 CONFIGURE_VARS+= $(if $(CONFIG_USE_GLIBC),LIBS='-lbsd -lpthread')
 CFLAGS+="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include"
 
-USB_IDS_REV:=0a6be488b4c1485d30c9efee1cc895af5d4a1383
-USB_IDS_FILE:=usb.ids.$(USB_IDS_REV)
+USB_IDS_VER:=0.318
+USB_IDS_FILE:=usb.ids.$(USB_IDS_VER)
 define Download/usb.ids
   FILE:=$(USB_IDS_FILE)
   URL_FILE:=usb.ids
-  URL:=@GITHUB/gentoo/hwids/$(USB_IDS_REV)
-  HASH:=2d0403ffccc0ff7150e32c0bf8e2878816b76ba08d2c3bb1059f33627a3da30f
+  URL:=@GITHUB/vcrhonek/hwdata/v$(USB_IDS_VER)
+  HASH:=84bc5452e4e45c2250e01bc74e03528b2a53c4724b2c4a5feaea76a922f83915
 endef
 
 define Package/usbip/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbip.so.* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/share/hwdata
-       $(CP) $(DL_DIR)/usb.ids.$(USB_IDS_REV) $(1)/usr/share/hwdata/usb.ids
+       $(CP) $(DL_DIR)/usb.ids.$(USB_IDS_VER) $(1)/usr/share/hwdata/usb.ids
 endef
 
 define Package/usbip-client/install