gstreamer1: Update to 1.14.4
authorRosen Penev <rosenp@gmail.com>
Fri, 12 Oct 2018 01:01:09 +0000 (18:01 -0700)
committerRosen Penev <rosenp@gmail.com>
Wed, 14 Nov 2018 21:43:11 +0000 (13:43 -0800)
Disabled a bunch more stuff through the configure script. Refreshed
patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
multimedia/gstreamer1/Makefile
multimedia/gstreamer1/patches/001-no-translations.patch
multimedia/gstreamer1/patches/002-no-tests.patch
multimedia/gstreamer1/patches/003-no-docs.patch
multimedia/gstreamer1/patches/010-gstplugin-use-lazy-symbol-binding.patch

index 2abe86483f2b9fe291d25ab621636bf419f09a38..01b621db287a8101cd09e4d72a58fbf63e427c66 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gstreamer1
-PKG_VERSION:=1.14.2
+PKG_VERSION:=1.14.4
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
@@ -19,8 +19,8 @@ PKG_LICENSE_FILES:=COPYING
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
 PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gstreamer/
-PKG_HASH:=4bd6127299f3f29379046bbd58a526e6353b569e0e72f7b4df2ae70df6882e09
+PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gstreamer
+PKG_HASH:=f94f6696c5f05a3b3a9183e39c5f5c0b779f75a04c0efa497e7920afa985ffc7
 
 PKG_FIXUP:=autoreconf
 PKG_REMOVE_FILES:=autogen.sh aclocal.m4
@@ -112,20 +112,24 @@ define Package/libgstreamer1/description
  .
  This package contains the GStreamer core library.
 endef
-  
+
 
 GST_VERSION:=1.0
 
 CONFIGURE_ARGS += \
        --enable-static \
+       --disable-benchmarks \
        --disable-examples \
+       --disable-failing-tests \
+       --disable-fatal-warnings \
+       --disable-introspection \
+       --disable-gst-tracer-hooks \
+       --disable-gtk-doc-html \
        --disable-tests \
        --disable-valgrind \
-       --disable-gst-tracer-hooks \
-       --with-unwind=no \
        --without-libiconv-prefix \
        --without-libintl-prefix \
-       --without-x \
+       --without-unwind
 
 EXTRA_LDFLAGS+= \
        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
index 1202812b9ced3ec4a56ff4ed11222b3ed910e83d..ae6cc27d80b782fc2349303a8c76c11732011b3f 100644 (file)
@@ -1,18 +1,6 @@
-diff -u --recursive gstreamer-1.12.4-vanilla/configure.ac gstreamer-1.12.4/configure.ac
---- gstreamer-1.12.4-vanilla/configure.ac      2018-02-10 17:37:16.379378242 -0500
-+++ gstreamer-1.12.4/configure.ac      2018-02-10 17:40:18.742109326 -0500
-@@ -1083,7 +1083,6 @@
- plugins/Makefile
- plugins/elements/Makefile
- plugins/tracers/Makefile
--po/Makefile.in
- tests/Makefile
- tests/benchmarks/Makefile
- tests/check/Makefile
-diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefile.am
---- gstreamer-1.12.4-vanilla/Makefile.am       2018-02-10 17:37:16.390378286 -0500
-+++ gstreamer-1.12.4/Makefile.am       2018-02-10 17:40:29.112150898 -0500
-@@ -9,7 +9,6 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -9,7 +9,6 @@ aclocal_DATA = gst-element-check-1.0.m4
  SUBDIRS = pkgconfig \
        gst libs plugins tests \
        docs \
@@ -20,7 +8,7 @@ diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefi
        m4 \
        common \
        data
-@@ -22,7 +21,6 @@
+@@ -22,7 +21,6 @@ endif
  DIST_SUBDIRS = pkgconfig \
        gst libs plugins tools tests \
        docs \
@@ -28,3 +16,13 @@ diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefi
        m4 \
        common \
        data
+--- a/configure.ac
++++ b/configure.ac
+@@ -1086,7 +1086,6 @@ libs/gst/net/Makefile
+ plugins/Makefile
+ plugins/elements/Makefile
+ plugins/tracers/Makefile
+-po/Makefile.in
+ tests/Makefile
+ tests/benchmarks/Makefile
+ tests/check/Makefile
index bc177daa244e8bae6b355e5a09bc1c7254495982..f3d711597ac405e68ed43d6d7bc135de208b7b81 100644 (file)
@@ -1,7 +1,26 @@
-diff -u --recursive gstreamer-1.12.4-vanilla/configure.ac gstreamer-1.12.4/configure.ac
---- gstreamer-1.12.4-vanilla/configure.ac      2018-02-10 17:43:59.957864211 -0500
-+++ gstreamer-1.12.4/configure.ac      2018-02-10 17:44:19.772930084 -0500
-@@ -1083,20 +1083,6 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -7,7 +7,7 @@ aclocaldir = $(datadir)/aclocal
+ aclocal_DATA = gst-element-check-1.0.m4
+ SUBDIRS = pkgconfig \
+-      gst libs plugins tests \
++      gst libs plugins \
+       docs \
+       m4 \
+       common \
+@@ -19,7 +19,7 @@ endif
+ # These are all the possible subdirs
+ DIST_SUBDIRS = pkgconfig \
+-      gst libs plugins tools tests \
++      gst libs plugins tools \
+       docs \
+       m4 \
+       common \
+--- a/configure.ac
++++ b/configure.ac
+@@ -1086,20 +1086,6 @@ libs/gst/net/Makefile
  plugins/Makefile
  plugins/elements/Makefile
  plugins/tracers/Makefile
@@ -22,24 +41,3 @@ diff -u --recursive gstreamer-1.12.4-vanilla/configure.ac gstreamer-1.12.4/confi
  tools/Makefile
  common/Makefile
  common/m4/Makefile
-diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefile.am
---- gstreamer-1.12.4-vanilla/Makefile.am       2018-02-10 17:43:59.959864217 -0500
-+++ gstreamer-1.12.4/Makefile.am       2018-02-10 17:44:30.298965075 -0500
-@@ -7,7 +7,7 @@
- aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
- SUBDIRS = pkgconfig \
--      gst libs plugins tests \
-+      gst libs plugins \
-       docs \
-       m4 \
-       common \
-@@ -19,7 +19,7 @@
- # These are all the possible subdirs
- DIST_SUBDIRS = pkgconfig \
--      gst libs plugins tools tests \
-+      gst libs plugins tools \
-       docs \
-       m4 \
-       common \
index d7b4a73a15d6a377fbfba9536a54edd862413cf3..b0f0e14cbd47f0c0e4539fc437358b1612dfe899 100644 (file)
@@ -1,23 +1,6 @@
-diff -u --recursive gstreamer-1.12.4-vanilla/configure.ac gstreamer-1.12.4/configure.ac
---- gstreamer-1.12.4-vanilla/configure.ac      2018-02-10 17:45:28.053157030 -0500
-+++ gstreamer-1.12.4/configure.ac      2018-02-10 17:45:47.703222322 -0500
-@@ -1086,12 +1086,6 @@
- tools/Makefile
- common/Makefile
- common/m4/Makefile
--docs/Makefile
--docs/gst/Makefile
--docs/gst/gstreamer.types
--docs/libs/Makefile
--docs/plugins/Makefile
--docs/version.entities
- m4/Makefile
- pkgconfig/Makefile
- stamp.h
-diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefile.am
---- gstreamer-1.12.4-vanilla/Makefile.am       2018-02-10 17:45:28.053157030 -0500
-+++ gstreamer-1.12.4/Makefile.am       2018-02-10 17:45:58.940259656 -0500
-@@ -8,7 +8,6 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -8,7 +8,6 @@ aclocal_DATA = gst-element-check-1.0.m4
  
  SUBDIRS = pkgconfig \
        gst libs plugins \
@@ -25,7 +8,7 @@ diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefi
        m4 \
        common \
        data
-@@ -20,7 +19,6 @@
+@@ -20,7 +19,6 @@ endif
  # These are all the possible subdirs
  DIST_SUBDIRS = pkgconfig \
        gst libs plugins tools \
@@ -33,3 +16,18 @@ diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefi
        m4 \
        common \
        data
+--- a/configure.ac
++++ b/configure.ac
+@@ -1089,12 +1089,6 @@ plugins/tracers/Makefile
+ tools/Makefile
+ common/Makefile
+ common/m4/Makefile
+-docs/Makefile
+-docs/gst/Makefile
+-docs/gst/gstreamer.types
+-docs/libs/Makefile
+-docs/plugins/Makefile
+-docs/version.entities
+ m4/Makefile
+ pkgconfig/Makefile
+ stamp.h
index 845406181921791a2379fa9eded502ba1943a5c8..976237b82f4f96b08bd92ca8d46938842f4b70a4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gst/gstplugin.c
 +++ b/gst/gstplugin.c
-@@ -732,15 +732,8 @@ _priv_gst_plugin_load_file_for_registry
+@@ -776,15 +776,8 @@ _priv_gst_plugin_load_file_for_registry (const gchar * filename,
      goto return_error;
    }