bridge-utils: fix conflict with busybox brctl
authorKonstantin Demin <rockdrilla@gmail.com>
Fri, 7 Jun 2019 19:52:44 +0000 (22:52 +0300)
committerYousong Zhou <yszhou4tech@gmail.com>
Mon, 10 Jun 2019 01:30:45 +0000 (01:30 +0000)
Busybox brctl applet conflicts with the version from bridge-utils.
Fix this by using ALTERNATIVE support for brctl in bridge-utils.

Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
[PKG_RELEASE bump]
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
net/bridge-utils/Makefile

index 81614d3e6a71cd3bcebd27aa533fc4801ac311b6..08b1e7f6539ace2144e7f5201b99a68866797a49 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=bridge-utils
 PKG_VERSION:=1.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/$(PKG_NAME)
@@ -28,6 +28,7 @@ define Package/bridge
   CATEGORY:=Base system
   TITLE:=Ethernet bridging configuration utility
   URL:=http://www.linuxfromscratch.org/blfs/view/svn/basicnet/bridge-utils.html
+  ALTERNATIVES:=300:/usr/sbin/brctl:/usr/libexec/bridge-utils-brctl
 endef
 
 define Package/bridge/description
@@ -41,15 +42,8 @@ CONFIGURE_ARGS += \
        --with-linux-headers="$(LINUX_DIR)" \
 
 define Package/bridge/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/sbin
-endef
-
-define Package/bridge/prerm
-#!/bin/sh
-$${IPKG_INSTROOT}/bin/busybox brctl -h 2>&1 | grep -q BusyBox && \
-ln -sf ../../bin/busybox $${IPKG_INSTROOT}/usr/sbin/brctl
-exit 0
+       $(INSTALL_DIR) $(1)/usr/libexec
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/libexec/bridge-utils-brctl
 endef
 
 $(eval $(call BuildPackage,bridge))