projects
/
feed
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1023114
)
python3: fix compilation
author
Rosen Penev
<rosenp@gmail.com>
Sun, 29 Nov 2020 06:02:53 +0000
(22:02 -0800)
committer
Hannu Nyman
<hannu.nyman@iki.fi>
Sun, 29 Nov 2020 11:58:13 +0000
(13:58 +0200)
Because of
e52d0487e88c3c8c57e1310d1a02b18eae0d142e
, these flags no
longer get passed. Add them back to fix compilation.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lang/python/python3/Makefile
patch
|
blob
|
history
diff --git
a/lang/python/python3/Makefile
b/lang/python/python3/Makefile
index 4cb5d37f5c1813d7c2ee648a0e0c9f75dd330740..0388a78281d7c654bdf9a3ec96894fe7275124ae 100644
(file)
--- a/
lang/python/python3/Makefile
+++ b/
lang/python/python3/Makefile
@@
-11,7
+11,7
@@
include $(TOPDIR)/rules.mk
include ../python3-version.mk
PKG_NAME:=python3
-PKG_RELEASE:=
1
+PKG_RELEASE:=
2
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
@@
-134,7
+134,8
@@
MAKE_FLAGS+=\
EXTRA_CFLAGS+= \
-DNDEBUG -fno-inline
EXTRA_LDFLAGS+= \
- -L$(PKG_BUILD_DIR)
+ -L$(PKG_BUILD_DIR) \
+ -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
DISABLE_BLUETOOTH:= \
ac_cv_header_bluetooth_bluetooth_h=no \