hcxdumptool: update to 6.1.6
authorRosen Penev <rosenp@gmail.com>
Mon, 12 Apr 2021 04:24:18 +0000 (21:24 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 13 Apr 2021 22:30:39 +0000 (15:30 -0700)
Fix compilation without deprecated OpenSSL APIs.

Backport upstream patch to fix stdout.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/hcxdumptool/Makefile
net/hcxdumptool/patches/010-openssl.patch [new file with mode: 0644]
net/hcxdumptool/patches/020-stdout.patch [new file with mode: 0644]

index 0f2cddf5d6a4345273905bfc92fa6a3b9d31e80c..94c757fd4c1eae792158d89ba8680ee1959a9268 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hcxdumptool
-PKG_VERSION:=6.0.1
-PKG_RELEASE:=1
+PKG_VERSION:=6.1.6
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/zerbea/hcxdumptool/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=32bc07b692f5682792dcfd1d5dcae749e5fed4a65a2a05d815ed59adc9b64b02
+PKG_HASH:=e3212bd808e228c28ecfeeb4a9709480aa178b2e8b15c0a7d96733b648f8da85
 
 PKG_MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
 PKG_LICENSE:=MIT
diff --git a/net/hcxdumptool/patches/010-openssl.patch b/net/hcxdumptool/patches/010-openssl.patch
new file mode 100644 (file)
index 0000000..a837737
--- /dev/null
@@ -0,0 +1,39 @@
+--- a/hcxdumptool.c
++++ b/hcxdumptool.c
+@@ -480,10 +480,6 @@ if(rebootflag == true)
+               }
+       }
+-EVP_cleanup();
+-CRYPTO_cleanup_all_ex_data();
+-ERR_free_strings();
+-
+ if(errorcount != 0) exit(EXIT_FAILURE);
+ if(totflag == true) exit(USER_EXIT_TOT);
+ exit(EXIT_SUCCESS);
+@@ -7270,8 +7266,6 @@ return true;
+ /*===========================================================================*/
+ static inline bool tlsinit()
+ {
+-SSL_load_error_strings();
+-OpenSSL_add_ssl_algorithms();
+ if((tlsctx = SSL_CTX_new(SSLv23_server_method())) == NULL)
+       {
+       fprintf(stderr, "OpenSSl can't create SSL context\n");
+@@ -7290,7 +7284,6 @@ if(SSL_CTX_use_PrivateKey_file(tlsctx, e
+ if((eaptlsctx = (eaptlsctx_t*)malloc(EAPTLSCTX_SIZE)) == NULL) return false;
+ memset(eaptlsctx, 0, EAPTLSCTX_SIZE);
+ SSL_CTX_set_session_cache_mode(tlsctx, SSL_SESS_CACHE_OFF);
+-SSL_CTX_set_ecdh_auto(tlsctx, 1);
+ SSL_CTX_set_verify(tlsctx, (SSL_VERIFY_PEER|SSL_VERIFY_CLIENT_ONCE), eap_tls_clientverify_cb);
+ #if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
+ SSL_CTX_set_min_proto_version(tlsctx, TLS1_VERSION);
+@@ -7364,8 +7357,6 @@ if(gpiostatusled > 0)
+       }
+-ERR_load_crypto_strings();
+-OpenSSL_add_all_algorithms();
+ opensslversion = OpenSSL_version_num();
+ opensslversionmajor = (opensslversion & 0x10000000L) >> 28;
+ opensslversionminor = (opensslversion & 0x01100000L) >> 20;
diff --git a/net/hcxdumptool/patches/020-stdout.patch b/net/hcxdumptool/patches/020-stdout.patch
new file mode 100644 (file)
index 0000000..53c6147
--- /dev/null
@@ -0,0 +1,21 @@
+From 63012853a81aa623f09304baf1f5b0b69f1ebfbd Mon Sep 17 00:00:00 2001
+From: Tristian <2220506+Tristian@users.noreply.github.com>
+Date: Tue, 16 Mar 2021 16:17:07 -0400
+Subject: [PATCH] fix assignment of read-only variable 'stdout'
+
+- stdout cannot be reassigned on some systems i.e OpenWRT on mipsel
+---
+ hcxdumptool.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/hcxdumptool.c
++++ b/hcxdumptool.c
+@@ -7958,7 +7958,7 @@ while((auswahl = getopt_long(argc, argv,
+                       else
+                               {
+                               fd_pcapng = fileno(stdout);
+-                              stdout = fopen("/dev/null", "w");
++                              freopen("/dev/null", "w", stdout);
+                               }
+                       }
+               pcapngoutname = optarg;