miniupnpd: update to 2.1.20191006
authorDENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Sat, 12 Oct 2019 06:36:55 +0000 (14:36 +0800)
committerDENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Sat, 12 Oct 2019 06:54:26 +0000 (14:54 +0800)
Removed upstreamed patch:
100-build-on-OpenWrt.patch

Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
net/miniupnpd/Makefile
net/miniupnpd/patches/100-build-on-OpenWrt.patch [deleted file]
net/miniupnpd/patches/200-remove-default-cflags.patch

index 886d95f86bb8c0242f1743982c9812562d1ac872..c35c4318aeb7a71b6597e40fbae0b5ded032186d 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miniupnpd
-PKG_VERSION:=2.1.20190408
-PKG_RELEASE:=2
+PKG_VERSION:=2.1.20191006
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=4175d588f600e2877503c781c5d75320dfce572669fcab7604434b07ec5c0d5d
+PKG_HASH:=218fad7af31f3c22fb4c9db28a55a2a8b5067d41f5b38f52008a057a00d2206d
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
diff --git a/net/miniupnpd/patches/100-build-on-OpenWrt.patch b/net/miniupnpd/patches/100-build-on-OpenWrt.patch
deleted file mode 100644 (file)
index a07ed38..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
---- a/genconfig.sh
-+++ b/genconfig.sh
-@@ -379,12 +379,19 @@ case $FW in
- esac
- # UUID API
--if grep uuid_create /usr/include/uuid.h > /dev/null 2>&1 ; then
--      echo "#define BSD_UUID" >> ${CONFIGFILE}
--fi
--if grep uuid_generate /usr/include/uuid/uuid.h > /dev/null 2>&1 ; then
--      echo "#define LIB_UUID" >> ${CONFIGFILE}
--fi
-+case $OS_NAME in
-+      OpenWRT)
-+              echo "#define LIB_UUID" >> ${CONFIGFILE}
-+              ;;
-+      *)
-+              if grep uuid_create /usr/include/uuid.h > /dev/null 2>&1 ; then
-+                      echo "#define BSD_UUID" >> ${CONFIGFILE}
-+              fi
-+              if grep uuid_generate /usr/include/uuid/uuid.h > /dev/null 2>&1 ; then
-+                      echo "#define LIB_UUID" >> ${CONFIGFILE}
-+              fi
-+      ;;
-+esac
- # set V6SOCKETS_ARE_V6ONLY to 0 if it was not set above
- if [ -z "$V6SOCKETS_ARE_V6ONLY" ] ; then
---- a/Makefile.linux
-+++ b/Makefile.linux
-@@ -77,7 +77,10 @@ CPPFLAGS += -DIPTABLES_143
- endif
- CFLAGS  += $(shell $(PKG_CONFIG) --cflags libiptc)
-+#OpenWrt packager passes correct libraries
-+ifeq ($(TARGET_OPENWRT),)
- LDLIBS  += $(shell $(PKG_CONFIG) --static --libs-only-l libiptc)
-+endif
- LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-L libiptc)
- LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-other libiptc)
- else
-@@ -157,6 +160,8 @@ LDLIBS += $(shell $(PKG_CONFIG) --static
- LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libnetfilter_conntrack)
- endif # ($(TEST),1)
-+# OpenWrt packager disables https server for IGD v2 and hardcodes libuuid support
-+ifeq ($(TARGET_OPENWRT),)
- LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libssl)
- TEST := $(shell $(PKG_CONFIG) --exists uuid && echo 1)
-@@ -165,6 +170,7 @@ LDLIBS += $(shell $(PKG_CONFIG) --static
- else
- $(info please install uuid-dev package / libuuid)
- endif # ($(TEST),1)
-+endif # ($(TARGET_OPENWRT,)
- GLIBC_VERSION := $(shell ldd --version | head -n 1 | sed 's/^.* //')
- GLIBC_VERSION_MAJOR = $(shell echo $(GLIBC_VERSION) | cut -f 1 -d . )
index 8ee8bf9504c072264f349eb20e1acaeb352cd282..462060450d587158a60102dc47efa79e27ec8a36 100644 (file)
@@ -1,7 +1,7 @@
 --- a/Makefile.linux
 +++ b/Makefile.linux
-@@ -23,16 +23,16 @@
- #
+@@ -24,16 +24,16 @@
+ CONFIG_OPTIONS += --firewall=iptables
  #CFLAGS = -O -g -DDEBUG
  CFLAGS ?= -Os
 -CFLAGS += -fno-strict-aliasing