libmariadb: fix compilation cmake issue
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 23 Jun 2021 09:54:30 +0000 (11:54 +0200)
committerFlorian Eckert <fe@dev.tdt.de>
Wed, 23 Jun 2021 10:06:33 +0000 (12:06 +0200)
This patch fixes the compilation issue of the upstream Cmake file.
If this patch is not applied we get the following compilation error output.

CMake Error at cmake/ConnectorName.cmake:30 (ENDMACRO):
  Flow control statements are not properly nested.
Call Stack (most recent call first):
  CMakeLists.txt:423 (INCLUDE)

The blamed cmake/ConnectorName.cmake file gets fixed with this patch.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
libs/libmariadb/patches/0001-libmariadb-fix-cmake.patch [new file with mode: 0644]

diff --git a/libs/libmariadb/patches/0001-libmariadb-fix-cmake.patch b/libs/libmariadb/patches/0001-libmariadb-fix-cmake.patch
new file mode 100644 (file)
index 0000000..01dd246
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/cmake/ConnectorName.cmake
++++ b/cmake/ConnectorName.cmake
+@@ -22,7 +22,7 @@ IF(CMAKE_SYSTEM_NAME MATCHES "Windows")
+     SET(MACHINE_NAME "x64")
+   ELSE()
+     SET(MACHINE_NAME "32")
+-  END()
++  ENDIF()
+ ENDIF()
+ SET(product_name "mysql-connector-c-${CPACK_PACKAGE_VERSION}-${PLATFORM_NAME}${CONCAT_SIGN}${MACHINE_NAME}")