projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
11590e7
)
try to add json #2
json-description
author
Alexander Couzens
<lynxis@fe80.eu>
Mon, 4 Mar 2019 00:45:18 +0000
(
01:45
+0100)
committer
Alexander Couzens
<lynxis@fe80.eu>
Mon, 4 Mar 2019 00:45:18 +0000
(
01:45
+0100)
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index 0818953ccb1fb13208b3cbe1964ef0e0d1d492ef..4b0c1ae85dedd1ee944ca46bcb9b80cdc826bbcf 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-520,7
+520,7
@@
define Device/Build/image
$(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2)): $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2))
cp $$^ $$@
- echo '{ "board": "$3", "type": "$2", "image": "$(call IMAGE_NAME,$(1),$(2))"
}' > $$@
.json
+ echo '{ "board": "$3", "type": "$2", "image": "$(call IMAGE_NAME,$(1),$(2))"
, "description": "$(DEVICE_TITLE)" }' > $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2))
.json
endef
define Device/Build/artifact