From: Felix Fietkau <nbd@openwrt.org>
Date: Fri, 21 Mar 2014 15:54:03 +0000 (+0000)
Subject: build: remove check for nonexistant CONFIG_TAR_VERBOSITY variable and move TAR_OPTION... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=00bcebeb4cabcaa630ee940f8bd15d29a563afa6;p=openwrt%2Fstaging%2Fsvanheule.git

build: remove check for nonexistant CONFIG_TAR_VERBOSITY variable and move TAR_OPTIONS to unpack.mk

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 39979
---

diff --git a/include/unpack.mk b/include/unpack.mk
index 2d35863095..2b33c4cd8e 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -11,6 +11,8 @@ ifneq ($(HOST_OS),Linux)
 else
   HOST_TAR:=$(TAR)
 endif
+
+TAR_OPTIONS:=-xf -
 TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
 UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
 
diff --git a/rules.mk b/rules.mk
index 5d63227339..0769a09278 100644
--- a/rules.mk
+++ b/rules.mk
@@ -272,12 +272,6 @@ else
   DISABLE_IPV6:=--disable-ipv6
 endif
 
-ifeq ($(CONFIG_TAR_VERBOSITY),y)
-  TAR_OPTIONS:=-xvf -
-else
-  TAR_OPTIONS:=-xf -
-endif
-
 ifeq ($(CONFIG_BUILD_LOG),y)
   BUILD_LOG:=1
 endif