From: Mike Baker <mbm@openwrt.org>
Date: Wed, 1 Feb 2006 10:47:17 +0000 (+0000)
Subject: move sysfs to mount_root
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=03c661a34fcb3b60558cf989598ce973e941f29b;p=openwrt%2Fstaging%2Flinusw.git

move sysfs to mount_root

SVN-Revision: 3107
---

diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index 958262761e..e4753d045c 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -55,6 +55,7 @@ $(IPKG_BASE):
 	cp -a ./default/* $(IDIR_BASE)
 	$(SED) 's,$$R,r$(REV),g' $(IDIR_BASE)/etc/banner
 	$(SED) 's,$$S,$(BOARD)-$(KERNEL),g' $(IDIR_BASE)/etc/ipkg.conf
+	mkdir -p $(IDIR_BASE)/sys
 	mkdir -p $(IDIR_BASE)/jffs
 	mkdir -p $(IDIR_BASE)/dev
 	mkdir -p $(IDIR_BASE)/proc
diff --git a/openwrt/package/base-files/default/etc/preinit b/openwrt/package/base-files/default/etc/preinit
index f82823ec9c..ac9039ca71 100755
--- a/openwrt/package/base-files/default/etc/preinit
+++ b/openwrt/package/base-files/default/etc/preinit
@@ -21,9 +21,4 @@ mount_root ${FAILSAFE:+failsafe}
 	{ mount|grep "on / type jffs2" 1>&-; } || firstboot
 }
 
-grep sysfs /proc/filesystems >&- 2>&- && {
-	mkdir -p /sys
-	mount -t sysfs none /sys
-}
-
 exec /sbin/init
diff --git a/openwrt/package/base-files/default/sbin/mount_root b/openwrt/package/base-files/default/sbin/mount_root
index bd9b815e12..427ff0444f 100755
--- a/openwrt/package/base-files/default/sbin/mount_root
+++ b/openwrt/package/base-files/default/sbin/mount_root
@@ -37,3 +37,4 @@ fi
 mount none /tmp -t tmpfs -o nosuid,nodev,mode=1777,size=50%
 mkdir -p /dev/pts
 mount none /dev/pts -t devpts
+grep sysfs /proc/filesystems >&- && mount -t sysfs none /sys