From: Rod Whitby <rod@whitby.id.au>
Date: Mon, 1 Jan 2007 05:29:29 +0000 (+0000)
Subject: Include the IXP4XX NPE microcode into the NSLU2 firmware image.
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=044897bd8a002484c6a43068754d464491d1dbf6;p=openwrt%2Fstaging%2Fwigyori.git

Include the IXP4XX NPE microcode into the NSLU2 firmware image.

SVN-Revision: 5952
---

diff --git a/target/linux/ixp4xx-2.6/image/Makefile b/target/linux/ixp4xx-2.6/image/Makefile
index 3c85823913..9359c5b11e 100644
--- a/target/linux/ixp4xx-2.6/image/Makefile
+++ b/target/linux/ixp4xx-2.6/image/Makefile
@@ -43,10 +43,9 @@ endef
 define Image/Build/jffs2-128k
 	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
 	BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-		-L $(KDIR)/apex-nslu2-armeb.bin \
+		-L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
 		-k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
 		-r Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
-		-m $(BIN_DIR)/NPE-B \
 		-p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
 endef