From: Joseph Tingiris <joseph.tingiris@gmail.com>
Date: Sun, 13 Jan 2019 21:43:48 +0000 (-0500)
Subject: base-files: change boot & umount STOP indexes
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=04811007e53c5a5bdddbd0a00b330e12a5dbd045;p=openwrt%2Fstaging%2Fnbd.git

base-files: change boot & umount STOP indexes

This patch is in a series to allow additional STOP indexes after umount,
so that other block devices may stop cleanly.

boot is now STOP=90
umount is now STOP=90

After this patch series, the resulting STOP indexes in the 80s & 90s
will be:

STOP=85 odhcpd.init
STOP=89 conntrackd.init
STOP=89 log.init
STOP=89 rssileds.init
STOP=90 boot
STOP=90 kdump.init
STOP=90 network
STOP=90 sysfixtime
STOP=90 umount
STOP=98 mdadm.init (note: will be addressed in a separate patch)

Signed-off-by: Joseph Tingiris <joseph.tingiris@gmail.com>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
[PKG_RELEASE is now 200]
---

diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index a6dee5aa5a..7129d488db 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=199
+PKG_RELEASE:=200
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/etc/init.d/boot b/package/base-files/files/etc/init.d/boot
index 31f245ffc7..09b7f44c79 100755
--- a/package/base-files/files/etc/init.d/boot
+++ b/package/base-files/files/etc/init.d/boot
@@ -2,7 +2,7 @@
 # Copyright (C) 2006-2011 OpenWrt.org
 
 START=10
-STOP=98
+STOP=90
 
 uci_apply_defaults() {
 	. /lib/functions/system.sh
diff --git a/package/base-files/files/etc/init.d/umount b/package/base-files/files/etc/init.d/umount
index 349b2b3264..57a4a6d90c 100755
--- a/package/base-files/files/etc/init.d/umount
+++ b/package/base-files/files/etc/init.d/umount
@@ -1,7 +1,7 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2006 OpenWrt.org
 
-STOP=99
+STOP=90
 stop() {
 	sync
 	/bin/umount -a -d -r