From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sat, 19 Mar 2016 11:00:09 +0000 (+0000)
Subject: linux-firmware: fix rt73-usb-firmware package
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=04f33f734973c5c9c108a7984b974d854d7db9a4;p=openwrt%2Fstaging%2Frobimarko.git

linux-firmware: fix rt73-usb-firmware package

Some parts of this package were named rt73-pci-firmware before which
looks like a copy and past error. This renames all parts to rt73-usb-
firmware and then the firmware gets build and the dependencies from the
package with the kernel module are also working correctly.

This fixes #22069

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>

SVN-Revision: 49037
---

diff --git a/package/firmware/linux-firmware/mediatek.mk b/package/firmware/linux-firmware/mediatek.mk
index 591ffee735..b258551a00 100644
--- a/package/firmware/linux-firmware/mediatek.mk
+++ b/package/firmware/linux-firmware/mediatek.mk
@@ -35,9 +35,9 @@ define Package/rt61-pci-firmware/install
 endef
 $(eval $(call BuildPackage,rt61-pci-firmware))
 
-Package/rt73-pci-firmware = $(call Package/firmware-default,Ralink RT2573 firmware)
+Package/rt73-usb-firmware = $(call Package/firmware-default,Ralink RT2573 firmware)
 define Package/rt73-usb-firmware/install
 	$(INSTALL_DIR) $(1)/lib/firmware
 	$(INSTALL_DATA) $(PKG_BUILD_DIR)/rt73.bin $(1)/lib/firmware/
 endef
-$(eval $(call BuildPackage,rt73-pci-firmware))
+$(eval $(call BuildPackage,rt73-usb-firmware))