From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 20 Feb 2012 09:03:17 +0000 (+0000)
Subject: kernel: strip unnecessary symbol table information from kernel modules, reduces defau... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=058d331a39077f159ca8922f1f422a1346d6aa67;p=openwrt%2Fstaging%2Fjow.git

kernel: strip unnecessary symbol table information from kernel modules, reduces default squashfs size on ar71xx by about 4k

SVN-Revision: 30657
---

diff --git a/target/linux/generic/patches-3.2/202-reduce_module_size.patch b/target/linux/generic/patches-3.2/202-reduce_module_size.patch
new file mode 100644
index 0000000000..58b4a7571c
--- /dev/null
+++ b/target/linux/generic/patches-3.2/202-reduce_module_size.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -374,7 +374,7 @@
+ KBUILD_AFLAGS   := -D__ASSEMBLY__
+ KBUILD_AFLAGS_MODULE  := -DMODULE
+ KBUILD_CFLAGS_MODULE  := -DMODULE
+-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
++KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -s
+ 
+ # Read KERNELRELEASE from include/config/kernel.release (if it exists)
+ KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
diff --git a/target/linux/generic/patches-3.2/321-powerpc_crtsavres_prereq.patch b/target/linux/generic/patches-3.2/321-powerpc_crtsavres_prereq.patch
index e5d383c715..eb42cf9dff 100644
--- a/target/linux/generic/patches-3.2/321-powerpc_crtsavres_prereq.patch
+++ b/target/linux/generic/patches-3.2/321-powerpc_crtsavres_prereq.patch
@@ -3,7 +3,7 @@
 @@ -375,6 +375,7 @@ KBUILD_AFLAGS   := -D__ASSEMBLY__
  KBUILD_AFLAGS_MODULE  := -DMODULE
  KBUILD_CFLAGS_MODULE  := -DMODULE
- KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
+ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -s
 +KBUILD_LDFLAGS_MODULE_PREREQ	:= 
  
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)
diff --git a/target/linux/generic/patches-3.3/202-reduce_module_size.patch b/target/linux/generic/patches-3.3/202-reduce_module_size.patch
new file mode 100644
index 0000000000..58b4a7571c
--- /dev/null
+++ b/target/linux/generic/patches-3.3/202-reduce_module_size.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -374,7 +374,7 @@
+ KBUILD_AFLAGS   := -D__ASSEMBLY__
+ KBUILD_AFLAGS_MODULE  := -DMODULE
+ KBUILD_CFLAGS_MODULE  := -DMODULE
+-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
++KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -s
+ 
+ # Read KERNELRELEASE from include/config/kernel.release (if it exists)
+ KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
diff --git a/target/linux/generic/patches-3.3/321-powerpc_crtsavres_prereq.patch b/target/linux/generic/patches-3.3/321-powerpc_crtsavres_prereq.patch
index e5d383c715..eb42cf9dff 100644
--- a/target/linux/generic/patches-3.3/321-powerpc_crtsavres_prereq.patch
+++ b/target/linux/generic/patches-3.3/321-powerpc_crtsavres_prereq.patch
@@ -3,7 +3,7 @@
 @@ -375,6 +375,7 @@ KBUILD_AFLAGS   := -D__ASSEMBLY__
  KBUILD_AFLAGS_MODULE  := -DMODULE
  KBUILD_CFLAGS_MODULE  := -DMODULE
- KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
+ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -s
 +KBUILD_LDFLAGS_MODULE_PREREQ	:= 
  
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)