From: Florian Fainelli <florian@openwrt.org>
Date: Wed, 22 Feb 2006 14:58:45 +0000 (+0000)
Subject: Added hci_usb to kmod-bluetooth. Closes #316
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=066228e64ece7c7d1eea6435bf02446e411f536f;p=openwrt%2Fstaging%2Fthess.git

Added hci_usb to kmod-bluetooth. Closes #316

SVN-Revision: 3263
---

diff --git a/openwrt/target/linux/aruba-2.6/config b/openwrt/target/linux/aruba-2.6/config
index afda3fad85..f560d7e4b2 100644
--- a/openwrt/target/linux/aruba-2.6/config
+++ b/openwrt/target/linux/aruba-2.6/config
@@ -469,7 +469,8 @@ CONFIG_BT_HIDP=m
 #
 # Bluetooth device drivers
 #
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
 CONFIG_BT_HCIUART=m
 CONFIG_BT_HCIUART_H4=y
 CONFIG_BT_HCIUART_BCSP=y
diff --git a/openwrt/target/linux/brcm-2.6/config b/openwrt/target/linux/brcm-2.6/config
index 303d8fd4f6..2cadc57898 100644
--- a/openwrt/target/linux/brcm-2.6/config
+++ b/openwrt/target/linux/brcm-2.6/config
@@ -562,7 +562,8 @@ CONFIG_BT_HIDP=m
 #
 # Bluetooth device drivers
 #
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
 CONFIG_BT_HCIUART=m
 CONFIG_BT_HCIUART_H4=y
 CONFIG_BT_HCIUART_BCSP=y
diff --git a/openwrt/target/linux/generic-2.6/modules.mk b/openwrt/target/linux/generic-2.6/modules.mk
index 4e8d2e9689..37d7094c5c 100644
--- a/openwrt/target/linux/generic-2.6/modules.mk
+++ b/openwrt/target/linux/generic-2.6/modules.mk
@@ -342,6 +342,7 @@ $(eval $(call KMOD_template,BLUETOOTH,bluetooth,\
 	$(MODULES_DIR)/kernel/net/bluetooth/sco.ko \
 	$(MODULES_DIR)/kernel/net/bluetooth/rfcomm/rfcomm.ko \
 	$(MODULES_DIR)/kernel/drivers/bluetooth/hci_uart.ko \
+	$(MODULES_DIR)/kernel/drivers/bluetooth/hci_usb.ko \
 ,CONFIG_BT))
 
 
diff --git a/openwrt/target/linux/x86-2.6/config b/openwrt/target/linux/x86-2.6/config
index 5347e6b7d4..339972b670 100644
--- a/openwrt/target/linux/x86-2.6/config
+++ b/openwrt/target/linux/x86-2.6/config
@@ -592,7 +592,8 @@ CONFIG_BT_HIDP=m
 #
 # Bluetooth device drivers
 #
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
 CONFIG_BT_HCIUART=m
 CONFIG_BT_HCIUART_H4=y
 CONFIG_BT_HCIUART_BCSP=y