From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sun, 14 Oct 2018 13:25:37 +0000 (+0200)
Subject: tools: patch: make patch build depend on automake
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=07e8c217cb79a19c59fcb34ea6de39aa91a625b6;p=openwrt%2Fstaging%2Fansuel.git

tools: patch: make patch build depend on automake

The Makefile.am changed and now patch wants to use automake to
regenerate the Makefile.in. Make sure automake was build before we build
patch.

This fixes build problem seen by the build bots.
Fixes: 4797dddfde6 ("patch: apply upstream cve fixes")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

diff --git a/tools/Makefile b/tools/Makefile
index 9a354f6c70..7d6a17e926 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -67,6 +67,7 @@ $(curdir)/bc/compile := $(curdir)/bison/compile
 $(curdir)/findutils/compile := $(curdir)/bison/compile
 $(curdir)/gengetopt/compile := $(curdir)/libtool/compile
 $(curdir)/patchelf/compile := $(curdir)/libtool/compile
+$(curdir)/patch/compile := $(curdir)/automake/compile
 $(curdir)/dosfstools/compile := $(curdir)/autoconf/compile $(curdir)/automake/compile
 $(curdir)/libressl/compile := $(curdir)/pkg-config/compile
 $(curdir)/mkimage/compile += $(curdir)/libressl/compile