From: John Crispin <john@openwrt.org>
Date: Tue, 14 Feb 2012 19:07:13 +0000 (+0000)
Subject: Add kernel module package for SLIP
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=07fb8159448a46a39921e64ca8611802f9213431;p=openwrt%2Fstaging%2Fnbd.git

Add kernel module package for SLIP

This patch adds support for a kernel module package for SLIP. We needed it forusing tunslip6 from Contiki OS for 6LoWPAN communications.

Signed-off-by: Markus Becker <mab@comnets.uni-bremen.de>

SVN-Revision: 30538
---

diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 93607302a2..bac681b75c 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -829,3 +829,28 @@ endef
 
 $(eval $(call KernelPackage,netem))
 
+define KernelPackage/slip
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=SLIP modules
+  KCONFIG:= \
+       CONFIG_SLIP \
+       CONFIG_SLIP_COMPRESSED=y \
+       CONFIG_SLIP_SMART=y \
+       CONFIG_SLIP_MODE_SLIP6=y
+
+  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.2)),1)
+    FILES:= \
+       $(LINUX_DIR)/drivers/net/slip/slip.ko
+  else
+    FILES:= \
+       $(LINUX_DIR)/drivers/net/slip.ko
+  endif
+  AUTOLOAD:=$(call AutoLoad,30,slip)
+endef
+
+define KernelPackage/slip/description
+ Kernel modules for SLIP support
+endef
+
+$(eval $(call KernelPackage,slip))
+