From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 21 Feb 2009 16:26:27 +0000 (+0000)
Subject: move the EABI config override to the generic kernel config overrides, as it's arch... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=08b408a4c555c5174e12f81e4685507ede9b78e5;p=openwrt%2Fstaging%2Fdangole.git

move the EABI config override to the generic kernel config overrides, as it's arch specific, not target specific - fixes spurious kernel rebuild issues with EABI

SVN-Revision: 14594
---

diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index f0639e39fe..de07b91189 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -91,6 +91,8 @@ define Kernel/Configure/Default
 	echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
 	echo "# CONFIG_KALLSYMS_ALL is not set" >> $(LINUX_DIR)/.config.target
 	echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target
+	$(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config.target
+	$(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config.target)
 	$(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config > $(LINUX_DIR)/.config.override
 	$(SCRIPT_DIR)/kconfig.pl 'm+' $(LINUX_DIR)/.config.target $(LINUX_DIR)/.config.override > $(LINUX_DIR)/.config
 	$(call Kernel/SetInitramfs)
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index cfe76d8bce..1499075f1d 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -16,12 +16,6 @@ LINUX_VERSION:=2.6.28.6
 
 include $(INCLUDE_DIR)/target.mk
 
-define Kernel/Configure
-	$(call Kernel/Configure/Default)
-	$(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-	$(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
-
 DEFAULT_PACKAGES += ixp4xx-microcode fconfig
 
 $(eval $(call BuildTarget))