From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sun, 15 Oct 2017 08:53:46 +0000 (+0200)
Subject: mac80211: ath6kl: add missing usb-core dependency to kmod-ath6kl-usb
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=08bbb804c88a74cd7a04cea548cebf85bcf09b8f;p=openwrt%2Fstaging%2Fynezz.git

mac80211: ath6kl: add missing usb-core dependency to kmod-ath6kl-usb

This fixes a build problem with many targets.

Fixes 618ed77a17422a ("mac80211: add ath6kl kernel modules")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index c0a430051d..7e9b5ad618 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -244,7 +244,7 @@ define KernelPackage/ath6kl-usb
   $(call KernelPackage/mac80211/Default)
   TITLE:=Atheros 802.11n USB wireless cards support
   URL:=https://wireless.wiki.kernel.org/en/users/drivers/ath6kl
-  DEPENDS+= @USB_SUPPORT +kmod-ath6kl
+  DEPENDS+= @USB_SUPPORT +kmod-usb-core +kmod-ath6kl
   FILES:= $(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath6kl/ath6kl_usb.ko
   AUTOLOAD:=$(call AutoProbe,ath6kl_usb)
 endef