From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 2 Sep 2008 15:50:09 +0000 (+0000)
Subject: make sure that when the kernel config changes, compile is triggered for all kernel... 
X-Git-Tag: reboot~25637
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=096531f61ee62814b9ae7f078eb9ca191099f322;p=openwrt%2Fopenwrt.git

make sure that when the kernel config changes, compile is triggered for all kernel dependent packages

SVN-Revision: 12503
---

diff --git a/include/kernel.mk b/include/kernel.mk
index 8393d2f420..5232148a6b 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -126,6 +126,8 @@ $(call KernelPackage/$(1)/config)
     endef
   endif
 
+  $(STAMP_BUILT): $(LINUX_DIR)/.config
+
   ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install