From: Felix Fietkau <nbd@nbd.name>
Date: Tue, 19 Jun 2018 08:06:50 +0000 (+0200)
Subject: ramips: limit dictionary size for lzma compression
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=09b6755946;p=openwrt%2Fstaging%2Fansuel.git

ramips: limit dictionary size for lzma compression

In some cases, recent builds fail to boot from flash with at least some
MT7621 based devices. The error message is:
"LZMA ERROR 1 - must RESET board to recover"
Booting the same kernel via TFTP works for some reason.

Through testing I figured out that limiting the LZMA dictionary size
seems to prevent these errors

Signed-off-by: Felix Fietkau <nbd@nbd.name>
---

diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 8ab8aa3a6c..cd77ffe411 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -31,7 +31,7 @@ loadaddr-$(CONFIG_TARGET_ramips_mt7621) := 0x80001000
 
 KERNEL_LOADADDR := $(loadaddr-y)
 
-KERNEL_DTB = kernel-bin | patch-dtb | lzma
+KERNEL_DTB = kernel-bin | patch-dtb | lzma -d21
 define Device/Default
   PROFILES = Default $$(DTS)
   KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)