From: Gabor Juhos <juhosg@openwrt.org>
Date: Fri, 24 Jan 2014 17:15:03 +0000 (+0000)
Subject: ar71xx: image: generate sysupgrade images for the Compex boards
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=09bf46d4189531cb530ad6514e795c30012bcd1a;p=openwrt%2Fstaging%2Fneocturne.git

ar71xx: image: generate sysupgrade images for the Compex boards

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 39391
---

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 5fe8ae4cbe..9cd9c26c36 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -457,11 +457,13 @@ define Image/Build/MyLoader
 	$(eval fwimage=$(KDIR_TMP)/$(2)-$(5)-firmware.bin)
 	$(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).bin.lzma,65536,$(KDIR)/root.$(1),$(fwsize),$(fwimage))
 	if [ -e "$(fwimage)" ]; then \
-		cp $(fwimage) $(call imgname,$(1),$(2))-$(5)-sysupgrade.bin; \
 		$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) -v \
 			-p0x00030000:0:al:0x80060000:firmware:$(fwimage) \
 			$(call imgname,$(1),$(2))-$(5)-factory.img; \
-		true; \
+		echo -n "" > $(KDIR_TMP)/empty.bin; \
+		sh $(TOPDIR)/scripts/combined-image.sh \
+			$(fwimage) $(KDIR_TMP)/empty.bin \
+			$(call imgname,$(1),$(2))-$(5)-sysupgrade.bin; \
 	fi
 endef