From: John Crispin <john@openwrt.org>
Date: Wed, 23 Apr 2014 07:52:47 +0000 (+0000)
Subject: mac80211: allow to select the rt2x00-soc module for the ramips/rt3883 subtarget
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0a1f5643811982482c55fc00ff5001c5dcd408dd;p=openwrt%2Fstaging%2Fdangole.git

mac80211: allow to select the rt2x00-soc module for the ramips/rt3883 subtarget

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 40560
---

diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 40f08e218c..bb80cfe59e 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -321,7 +321,7 @@ endef
 
 define KernelPackage/rt2800-soc
 $(call KernelPackage/rt2x00/Default)
-  DEPENDS += @(TARGET_ramips_rt288x||TARGET_ramips_rt305x) +kmod-rt2800-mmio +kmod-rt2800-lib
+  DEPENDS += @(TARGET_ramips_rt288x||TARGET_ramips_rt305x||TARGET_ramips_rt3883) +kmod-rt2800-mmio +kmod-rt2800-lib
   TITLE += (RT28xx/RT3xxx SoC)
   FILES := \
 	$(PKG_BUILD_DIR)/drivers/net/wireless/rt2x00/rt2x00soc.ko \