From: Felix Fietkau <nbd@nbd.name>
Date: Tue, 21 Feb 2017 19:43:35 +0000 (+0100)
Subject: build: skip opkg host dependency within the SDK
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0aa46bf76ab01fe1f64b0992fe2a8196c3b19d89;p=openwrt%2Fstaging%2Fynezz.git

build: skip opkg host dependency within the SDK

Signed-off-by: Felix Fietkau <nbd@nbd.name>
---

diff --git a/package/Makefile b/package/Makefile
index 1ef501736b..ac8faecef2 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -56,7 +56,9 @@ $(curdir)/merge:
 $(curdir)/merge-index: $(curdir)/merge
 	(cd $(PACKAGE_DIR_ALL) && $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages; )
 
-$(curdir)/compile: $(curdir)/system/opkg/host/compile
+ifndef SDK
+  $(curdir)/compile: $(curdir)/system/opkg/host/compile
+endif
 
 $(curdir)/install: $(TMP_DIR)/.build $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
 	- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755