From: Eric Luehrsen <ericluehrsen@gmail.com>
Date: Wed, 5 Dec 2018 05:31:05 +0000 (-0500)
Subject: unbound: update to 1.8.2
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0b4da5d97d61e138859ad4da5b75da5a3c82384e;p=feed%2Fpackages.git

unbound: update to 1.8.2

Signed-off-by: Eric Luehrsen <ericluehrsen@gmail.com>
---

diff --git a/net/unbound/Makefile b/net/unbound/Makefile
index e492c1372d..6605f2946a 100644
--- a/net/unbound/Makefile
+++ b/net/unbound/Makefile
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=unbound
-PKG_VERSION:=1.8.1
-PKG_RELEASE:=3
+PKG_VERSION:=1.8.2
+PKG_RELEASE:=1
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
@@ -17,7 +17,7 @@ PKG_MAINTAINER:=Eric Luehrsen <ericluehrsen@gmail.com>
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.unbound.net/downloads
-PKG_HASH:=c362b3b9c35d1b8c1918da02cdd5528d729206c14c767add89ae95acae363c5d
+PKG_HASH:=19f2235a8936d89e7dc919bbfcef355de759f220e36bb5e1e931ac000ed04993
 
 PKG_BUILD_PARALLEL:=1
 PKG_FIXUP:=autoreconf
diff --git a/net/unbound/patches/200-openssl-deprecated.patch b/net/unbound/patches/200-openssl-deprecated.patch
index 118a82ccc2..6eaa082faf 100644
--- a/net/unbound/patches/200-openssl-deprecated.patch
+++ b/net/unbound/patches/200-openssl-deprecated.patch
@@ -1,5 +1,5 @@
-diff --git a/daemon/daemon.c b/daemon/daemon.c
-index 4c3d5f1..50f5060 100644
+Index: daemon/daemon.c
+===================================================================
 --- a/daemon/daemon.c
 +++ b/daemon/daemon.c
 @@ -769,7 +769,7 @@ daemon_delete(struct daemon* daemon)
@@ -11,8 +11,8 @@ index 4c3d5f1..50f5060 100644
  	ENGINE_cleanup();
  #  endif
  	CONF_modules_free();
-diff --git a/util/net_help.c b/util/net_help.c
-index 91368c8..a932010 100644
+Index: util/net_help.c
+===================================================================
 --- a/util/net_help.c
 +++ b/util/net_help.c
 @@ -1006,10 +1006,10 @@ void* outgoing_ssl_fd(void* sslctx, int fd)