From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 6 May 2014 17:26:32 +0000 (+0000)
Subject: ltq-vdsl: force shell to bash to avoid compile errors
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0b89008f7f3b590653a73e98cd9eff938c2f2837;p=openwrt%2Fstaging%2Fstintel.git

ltq-vdsl: force shell to bash to avoid compile errors

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 40713
---

diff --git a/package/kernel/lantiq/ltq-vdsl/Makefile b/package/kernel/lantiq/ltq-vdsl/Makefile
index 0901721b90..d14d4bc955 100644
--- a/package/kernel/lantiq/ltq-vdsl/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl/Makefile
@@ -40,6 +40,9 @@ endef
 
 EXTRA_CFLAGS = -fno-pic -mno-abicalls -mlong-calls -G 0
 
+MAKE_FLAGS += \
+	SHELL="$(BASH)"
+
 CONFIGURE_ARGS += --enable-kernel-include="$(LINUX_DIR)/include" \
 	--with-max-device="1" \
 	--with-lines-per-device="1" \