From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 10 Oct 2005 12:13:04 +0000 (+0000)
Subject: add binutils 2.16.1, current whiterussian binutils seem to break on some 64 bit machi... 
X-Git-Tag: whiterussian_rc4~122
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0c424aba7a32eb1fbbdd8e010174035d4ef14fb7;p=openwrt%2Fsvn-archive%2Fopenwrt.git

add binutils 2.16.1, current whiterussian binutils seem to break on some 64 bit machines - maybe we should switch later

SVN-Revision: 2096
---

diff --git a/openwrt/toolchain/binutils/Config.in b/openwrt/toolchain/binutils/Config.in
index fdec263644..1dda7d4268 100644
--- a/openwrt/toolchain/binutils/Config.in
+++ b/openwrt/toolchain/binutils/Config.in
@@ -18,6 +18,10 @@ choice
 
 	config BR2_BINUTILS_VERSION_2_15_94_0_2_2
 		bool "binutils 2.15.94.0.2.2"
+		
+	config BR2_BINUTILS_VERSION_2_16_1
+		bool "binutils 2.16.1"
+
 
 
 endchoice
@@ -27,3 +31,4 @@ config BR2_BINUTILS_VERSION
 	default "2.15"            if BR2_BINUTILS_VERSION_2_15
 	default "2.15.94.0.2"     if BR2_BINUTILS_VERSION_2_15_94_0_2 || !CONFIG_DEVEL
 	default "2.15.94.0.2.2"   if BR2_BINUTILS_VERSION_2_15_94_0_2_2
+	default "2.16.1"          if BR2_BINUTILS_VERSION_2_16_1
diff --git a/openwrt/toolchain/binutils/Makefile b/openwrt/toolchain/binutils/Makefile
index e3bee5da17..806ecd05fb 100644
--- a/openwrt/toolchain/binutils/Makefile
+++ b/openwrt/toolchain/binutils/Makefile
@@ -13,6 +13,14 @@ BINUTILS_SITE:=http://www.fr.kernel.org/pub/linux/devel/binutils \
 	       http://ftp.kernel.org/pub/linux/devel/binutils \
 	       http://www.de.kernel.org/pub/linux/devel/binutils
 
+ifeq ($(BINUTILS_VERSION),2.16.1)
+BINUTILS_SITE:=http://ftp.gnu.org/gnu/binutils/ \
+	ftp://gatekeeper.dec.com/pub/GNU/ \
+        ftp://ftp.uu.net/archive/systems/gnu/ \
+        ftp://ftp.eu.uu.net/pub/gnu/ \
+        ftp://ftp.funet.fi/pub/gnu/prep/ \
+        ftp://ftp.leo.org/pub/comp/os/unix/gnu/ 
+endif
 ifeq ($(BINUTILS_VERSION),2.15)
 BINUTILS_SITE:=http://ftp.gnu.org/gnu/binutils/ \
 	ftp://gatekeeper.dec.com/pub/GNU/ \