From: Koen Vandeputte <koen.vandeputte@ncentric.com>
Date: Mon, 15 Oct 2018 09:19:43 +0000 (+0200)
Subject: kernel: bump 4.14 to 4.14.76
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0d0bd8e6da9d93d8b8ae6a936d564fbeb39c6f77;p=openwrt%2Fstaging%2Fansuel.git

kernel: bump 4.14 to 4.14.76

Refreshed all patches.

Compile-tested on: ar71xx, cns3xxx, imx6
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
---

diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index f874160742..5cb3742523 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .124
 LINUX_VERSION-4.9 = .133
-LINUX_VERSION-4.14 = .75
+LINUX_VERSION-4.14 = .76
 
 LINUX_KERNEL_HASH-3.18.124 = 25d2a5abd627534a1e51d028890c184aad8e628c345c5fe0cc0f9d7c31b7a5a3
 LINUX_KERNEL_HASH-4.9.133 = 53730fc025ba330a6f4908a6a1e4cb86d821000c84167721680ccf1b37b26563
-LINUX_KERNEL_HASH-4.14.75 = 5093d7230b8f1c553450ca6c1ccd20a46a055d9277a7e161039a8642b3398120
+LINUX_KERNEL_HASH-4.14.76 = ee3f19a4ff8a42793c193e361e1d34fcc821a5ca9b58db41befb2b4df0e482be
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/apm821xx/patches-4.14/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch b/target/linux/apm821xx/patches-4.14/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
index e8154253a3..5d9b1f6061 100644
--- a/target/linux/apm821xx/patches-4.14/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
+++ b/target/linux/apm821xx/patches-4.14/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
@@ -44,7 +44,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  
  #include "xhci.h"
  #include "xhci-trace.h"
-@@ -255,6 +257,458 @@ static void xhci_pme_acpi_rtd3_enable(st
+@@ -257,6 +259,458 @@ static void xhci_pme_acpi_rtd3_enable(st
  static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
  #endif /* CONFIG_ACPI */
  
@@ -503,7 +503,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  /* called during probe() after chip reset completes */
  static int xhci_pci_setup(struct usb_hcd *hcd)
  {
-@@ -290,6 +744,22 @@ static int xhci_pci_probe(struct pci_dev
+@@ -292,6 +746,22 @@ static int xhci_pci_probe(struct pci_dev
  	struct hc_driver *driver;
  	struct usb_hcd *hcd;
  
@@ -526,7 +526,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  	driver = (struct hc_driver *)id->driver_data;
  
  	/* For some HW implementation, a XHCI reset is just not enough... */
-@@ -354,6 +824,16 @@ static void xhci_pci_remove(struct pci_d
+@@ -356,6 +826,16 @@ static void xhci_pci_remove(struct pci_d
  {
  	struct xhci_hcd *xhci;
  
diff --git a/target/linux/apm821xx/patches-4.14/802-usb-xhci-force-msi-renesas-xhci.patch b/target/linux/apm821xx/patches-4.14/802-usb-xhci-force-msi-renesas-xhci.patch
index c09d1547bd..141b839d68 100644
--- a/target/linux/apm821xx/patches-4.14/802-usb-xhci-force-msi-renesas-xhci.patch
+++ b/target/linux/apm821xx/patches-4.14/802-usb-xhci-force-msi-renesas-xhci.patch
@@ -13,7 +13,7 @@ produce a noisy warning.
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -213,7 +213,7 @@ static void xhci_pci_quirks(struct devic
+@@ -215,7 +215,7 @@ static void xhci_pci_quirks(struct devic
  		xhci->quirks |= XHCI_TRUST_TX_LENGTH;
  	if (pdev->vendor == PCI_VENDOR_ID_RENESAS &&
  			pdev->device == 0x0015)
diff --git a/target/linux/generic/hack-4.14/902-debloat_proc.patch b/target/linux/generic/hack-4.14/902-debloat_proc.patch
index e89786b47a..54c9bd40a0 100644
--- a/target/linux/generic/hack-4.14/902-debloat_proc.patch
+++ b/target/linux/generic/hack-4.14/902-debloat_proc.patch
@@ -243,7 +243,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
-@@ -1944,10 +1944,12 @@ void __init init_mm_internals(void)
+@@ -1947,10 +1947,12 @@ void __init init_mm_internals(void)
  	start_shepherd_timer();
  #endif
  #ifdef CONFIG_PROC_FS
diff --git a/target/linux/mediatek/patches-4.14/0191-usb-xhci-allow-imod-interval-to-be-configurable.patch b/target/linux/mediatek/patches-4.14/0191-usb-xhci-allow-imod-interval-to-be-configurable.patch
index 5230487739..ded3916c5c 100644
--- a/target/linux/mediatek/patches-4.14/0191-usb-xhci-allow-imod-interval-to-be-configurable.patch
+++ b/target/linux/mediatek/patches-4.14/0191-usb-xhci-allow-imod-interval-to-be-configurable.patch
@@ -86,7 +86,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
  	if (!xhci->shared_hcd) {
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -266,6 +266,9 @@ static int xhci_pci_setup(struct usb_hcd
+@@ -268,6 +268,9 @@ static int xhci_pci_setup(struct usb_hcd
  	if (!xhci->sbrn)
  		pci_read_config_byte(pdev, XHCI_SBRN_OFFSET, &xhci->sbrn);
  
diff --git a/target/linux/mpc85xx/patches-4.14/001-powerpc-85xx-add-gpio-keys-to-of-match-table.patch b/target/linux/mpc85xx/patches-4.14/001-powerpc-85xx-add-gpio-keys-to-of-match-table.patch
index ee0c4d784d..58c4be6007 100644
--- a/target/linux/mpc85xx/patches-4.14/001-powerpc-85xx-add-gpio-keys-to-of-match-table.patch
+++ b/target/linux/mpc85xx/patches-4.14/001-powerpc-85xx-add-gpio-keys-to-of-match-table.patch
@@ -1,10 +1,10 @@
 --- a/arch/powerpc/platforms/85xx/common.c
 +++ b/arch/powerpc/platforms/85xx/common.c
 @@ -33,6 +33,7 @@ static const struct of_device_id mpc85xx
-	{ .compatible = "fsl,mpc8548-guts", },
-	/* Probably unnecessary? */
-	{ .compatible = "gpio-leds", },
+ 	{ .compatible = "fsl,mpc8548-guts", },
+ 	/* Probably unnecessary? */
+ 	{ .compatible = "gpio-leds", },
 +	{ .compatible = "gpio-keys", },
-	/* For all PCI controllers */
-	{ .compatible = "fsl,mpc8540-pci", },
-	{ .compatible = "fsl,mpc8548-pcie", },
+ 	/* For all PCI controllers */
+ 	{ .compatible = "fsl,mpc8540-pci", },
+ 	{ .compatible = "fsl,mpc8548-pcie", },
diff --git a/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch b/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch
index b99d0da863..8b627fb729 100644
--- a/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch
+++ b/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch
@@ -22,7 +22,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
 +src-plat-$(CONFIG_TL_WDR4900_V1) += cuboot-tl-wdr4900-v1.c
-
+ 
  src-wlib := $(sort $(src-wlib-y))
  src-plat := $(sort $(src-plat-y))
 @@ -330,7 +331,7 @@ image-$(CONFIG_TQM8555)			+= cuImage.tqm
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 +image-$(CONFIG_TL_WDR4900_V1)		+= cuImage.tl-wdr4900-v1
  # Board ports in arch/powerpc/platform/86xx/Kconfig
  image-$(CONFIG_MVME7100)                += dtbImage.mvme7100
-
+ 
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
 @@ -277,6 +277,10 @@ cuboot*)
@@ -50,9 +50,9 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
 @@ -170,6 +170,17 @@ config STX_GP3
-	select CPM2
-	select DEFAULT_UIMAGE
-
+ 	select CPM2
+ 	select DEFAULT_UIMAGE
+ 
 +config TL_WDR4900_V1
 +    bool "TP-Link TL-WDR4900 v1"
 +    select DEFAULT_UIMAGE
@@ -65,8 +65,8 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 +      Freescale P1014 SoC.
 +
  config TQM8540
-	bool "TQ Components TQM8540"
-	help
+ 	bool "TQ Components TQM8540"
+ 	help
 --- a/arch/powerpc/platforms/85xx/Makefile
 +++ b/arch/powerpc/platforms/85xx/Makefile
 @@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC)   += coren
diff --git a/target/linux/mpc85xx/patches-4.14/101-powerpc-85xx-hiveap-330-support.patch b/target/linux/mpc85xx/patches-4.14/101-powerpc-85xx-hiveap-330-support.patch
index 519566bc15..34568398c2 100644
--- a/target/linux/mpc85xx/patches-4.14/101-powerpc-85xx-hiveap-330-support.patch
+++ b/target/linux/mpc85xx/patches-4.14/101-powerpc-85xx-hiveap-330-support.patch
@@ -1,9 +1,9 @@
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
 @@ -49,6 +49,17 @@ config BSC9132_QDS
-	  and dual StarCore SC3850 DSP cores.
-	  Manufacturer : Freescale Semiconductor, Inc
-
+ 	  and dual StarCore SC3850 DSP cores.
+ 	  Manufacturer : Freescale Semiconductor, Inc
+ 
 +config HIVEAP_330
 +    bool "Aerohive HiveAP-330"
 +    select DEFAULT_UIMAGE
@@ -16,8 +16,8 @@
 +      Freescale P1020 SoC.
 +
  config MPC8540_ADS
-	bool "Freescale MPC8540 ADS"
-	select DEFAULT_UIMAGE
+ 	bool "Freescale MPC8540 ADS"
+ 	select DEFAULT_UIMAGE
 --- a/arch/powerpc/platforms/85xx/Makefile
 +++ b/arch/powerpc/platforms/85xx/Makefile
 @@ -10,6 +10,7 @@ obj-y += common.o
diff --git a/target/linux/mpc85xx/patches-4.14/102-powerpc-add-cmdline-override.patch b/target/linux/mpc85xx/patches-4.14/102-powerpc-add-cmdline-override.patch
index 7f4fa249d0..a3b69bbbb3 100644
--- a/target/linux/mpc85xx/patches-4.14/102-powerpc-add-cmdline-override.patch
+++ b/target/linux/mpc85xx/patches-4.14/102-powerpc-add-cmdline-override.patch
@@ -1,9 +1,9 @@
 --- a/arch/powerpc/Kconfig
 +++ b/arch/powerpc/Kconfig
 @@ -830,6 +830,14 @@ config CMDLINE_FORCE
-	  This is useful if you cannot or don't want to change the
-	  command-line options your boot loader passes to the kernel.
-
+ 	  This is useful if you cannot or don't want to change the
+ 	  command-line options your boot loader passes to the kernel.
+ 
 +config CMDLINE_OVERRIDE
 +    bool "Use alternative cmdline from device tree"
 +    help
@@ -13,14 +13,14 @@
 +      cmdline if it exists in the device tree.
 +
  config EXTRA_TARGETS
-	string "Additional default image types"
-	help
+ 	string "Additional default image types"
+ 	help
 --- a/drivers/of/fdt.c
 +++ b/drivers/of/fdt.c
 @@ -1131,6 +1131,17 @@ int __init early_init_dt_scan_chosen(uns
-	if (p != NULL && l > 0)
-		strlcpy(data, p, min((int)l, COMMAND_LINE_SIZE));
-
+ 	if (p != NULL && l > 0)
+ 		strlcpy(data, p, min((int)l, COMMAND_LINE_SIZE));
+ 
 +    /* CONFIG_CMDLINE_OVERRIDE is used to fallback to a different
 +     * device tree option of chosen/bootargs-override. This is
 +     * helpful on boards where u-boot sets bootargs, and is unable
@@ -32,6 +32,6 @@
 +		strlcpy(data, p, min((int)l, COMMAND_LINE_SIZE));
 +#endif
 +
-	/*
-	 * CONFIG_CMDLINE is meant to be a default in case nothing else
-	 * managed to set the command line, unless CONFIG_CMDLINE_FORCE
+ 	/*
+ 	 * CONFIG_CMDLINE is meant to be a default in case nothing else
+ 	 * managed to set the command line, unless CONFIG_CMDLINE_FORCE