From: John Crispin <john@openwrt.org>
Date: Mon, 17 Aug 2015 06:01:23 +0000 (+0000)
Subject: ramips: remove old code for Edimax BR-6524N
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0d464c360f0de4d90c8b25b2b2960ac7b5392cae;p=openwrt%2Fstaging%2Fansuel.git

ramips: remove old code for Edimax BR-6524N

It seems that support for Edimax BR-6524N was dropped long time ago (dts file for this device is missing).
This patch removes remaining code.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>

SVN-Revision: 46630
---

diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 1456be1abf..e872b39ffe 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -70,9 +70,6 @@ case $board in
 		set_usb_led "red:diskmounted"
 		set_wifi_led "red:wps_active"
 		;;
-	br6524n)
-		set_wifi_led "edimax:blue:wlan"
-		;;
 	cf-wr800n)
 		ucidef_set_led_netdev "lan" "lan" "comfast:white:ethernet" eth0.1
 		set_wifi_led "comfast:white:wifi"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 334003d1ee..8c19b40de6 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -182,7 +182,6 @@ ramips_setup_interfaces()
 		ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
 		;;
 
-	br6524n | \
 	v11st-fe)
 		ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
 		ucidef_add_switch "switch0" "1" "1"
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index f63cf31cb3..1e0a15efce 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -33,9 +33,6 @@ get_status_led() {
 	asl26555)
 		status_led="asl26555:green:power"
 		;;
-	br6524n)
-		status_led="edimax:blue:power"
-		;;
 	br-6425 | br-6475nd)
 		status_led="edimax:green:power"
 		;;
diff --git a/target/linux/ramips/rt288x/profiles/edimax.mk b/target/linux/ramips/rt288x/profiles/edimax.mk
deleted file mode 100644
index 43ac818370..0000000000
--- a/target/linux/ramips/rt288x/profiles/edimax.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/BR6524N
-       NAME:=Edimax BR6524N
-       PACKAGES:=kmod-switch-ip17xx kmod-swconfig swconfig
-endef
-
-define Profile/BR6524N/Description
-       Package set for Edimax BR6524N
-endef
-
-$(eval $(call Profile,BR6524N))
-