From: Gabor Juhos <juhosg@openwrt.org>
Date: Mon, 9 Jul 2007 16:36:19 +0000 (+0000)
Subject: disable image generation for boards which we still have problems with (at least if... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0e1921ab3c64838dce369538c2e0fcbebaed89ac;p=openwrt%2Fstaging%2Fsvanheule.git

disable image generation for boards which we still have problems with (at least if CONFIG_DEVEL is not selected)

SVN-Revision: 7902
---

diff --git a/target/linux/adm5120-2.6/image/Makefile b/target/linux/adm5120-2.6/image/Makefile
index 732b82de3e..352ebf480f 100644
--- a/target/linux/adm5120-2.6/image/Makefile
+++ b/target/linux/adm5120-2.6/image/Makefile
@@ -82,7 +82,7 @@ root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
 endef
 
 define Image/Build/RouterBoard
-	$(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-vmlinux
+	$(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-rb1xx-vmlinux
 	$(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/yaffs2)) '
 endef
 
@@ -91,6 +91,7 @@ define Image/Build
 ifneq ($(1),jffs2-256k)
 ifneq ($(1),jffs2-128k)
 	$(call Image/Build/Compex,$(1),wp54g-wrt,$(patsubst jffs2-%,jffs2,$(1)),WP54G-WRT)
+ifeq (CONFIG_DEVEL,y)
 	$(call Image/Build/Edimax,$(1),br-6104k,$(patsubst jffs2-%,jffs2,$(1)),BR-6104K)
 	$(call Image/Build/Edimax,$(1),br-6104kp,$(patsubst jffs2-%,jffs2,$(1)),BR-6104KP)
 	$(call Image/Build/Edimax,$(1),br-6114wg,$(patsubst jffs2-%,jffs2,$(1)),BR-6114WG)
@@ -117,6 +118,7 @@ ifneq ($(1),jffs2-128k)
 	$(call Image/Build/MyLoader,$(1),wpp54ag,$(patsubst jffs2-%,jffs2,$(1)),WPP54AG)
 endif
 endif
+endif
 ifeq ($(1),tgz)
 	$(call Image/Build/RouterBoard)
 endif
@@ -143,12 +145,17 @@ define Image/Build/LZMAKernel/Admboot
 	$(call Image/Build/LZMAKernel,$(1),$(2),0x80500000,0x6D8,y,$(1))
 endef
 
+define Image/Build/Initramfs/RouterBoard
+	$(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-ramfs-rb1xx.elf
+endef
+
 define Image/Build/Initramfs
+	$(call Image/Build/Initramfs/RouterBoard)
+	$(call Image/Build/LZMAKernel/Compex,wp54g-wrt,bin)
+ifeq (CONFIG_DEVEL,y)
 	$(call Image/Build/LZMAKernel/Generic,generic,bin)
-	$(call Image/Build/LZMAKernel/Generic,rb-100,elf)
 	$(call Image/Build/LZMAKernel/Generic,np27g,bin)
 	$(call Image/Build/LZMAKernel/Generic,wp54g,bin)
-	$(call Image/Build/LZMAKernel/Compex,wp54g-wrt,bin)
 	$(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
 	$(call Image/Build/LZMAKernel/Admboot,easy-5120,gz)
 	$(call Image/Build/LZMAKernel/Admboot,easy-83000,gz)
@@ -158,6 +165,7 @@ define Image/Build/Initramfs
 	$(call Image/Build/LZMAKernel/Admboot,cas-771,gz)
 	$(call Image/Build/LZMAKernel/Admboot,cas-790,gz)
 	$(call Image/Build/LZMAKernel/Admboot,cas-861,gz)
+endif
 endef
 
 $(eval $(call BuildImage))
diff --git a/target/linux/adm5120-2.6/image/lzma-loader/src/board.c b/target/linux/adm5120-2.6/image/lzma-loader/src/board.c
index 616e7562a8..baffe04ef1 100644
--- a/target/linux/adm5120-2.6/image/lzma-loader/src/board.c
+++ b/target/linux/adm5120-2.6/image/lzma-loader/src/board.c
@@ -1,5 +1,5 @@
 /*
- * ADM5120 specific board support for LZMA decompressor 
+ * ADM5120 specific board support for LZMA decompressor
  *
  * Copyright (C) 2007 OpenWrt.org
  * Copyright (C) 2007 Gabor Juhos <juhosg@freemail.hu>
@@ -24,7 +24,7 @@
 #define READREG(r)	*(volatile unsigned int *)(r)
 #define WRITEREG(r,v)	*(volatile unsigned int *)(r) = v
 
-/* 
+/*
  * INTC definitions
  */
 #define INTC_BASE	0xB2200000
@@ -32,7 +32,7 @@
 /* INTC registers */
 #define INTC_REG_IRQ_DISABLE	0x0C
 
-/* 
+/*
  * UART definitions
  */
 #define UART_BASE	0xB2600000
@@ -61,7 +61,7 @@
 #define UART_FLAG_RXFF	( 1 << 6 )	/* RX FIFO full */
 #define UART_FLAG_TXFE	( 1 << 7 )	/* TX FIFO empty */
 
-/* 
+/*
  * SWITCH definitions
  */
 #define SWITCH_BASE	0xB2000000
@@ -96,8 +96,9 @@
 
 static void uart_init(void)
 {
+#if 0
 	unsigned int t;
-	
+
 	/* disable uart */
 	UART_WRITE(UART_REG_CTRL, 0);
 
@@ -106,7 +107,7 @@ static void uart_init(void)
 	UART_WRITE(UART_REG_LCRM, t);
 	t = UART_READ(UART_REG_LCRL);
 	UART_WRITE(UART_REG_LCRL, t);
-	
+
 	/* keep data, stop, and parity bits, but disable FIFO */
 	t = UART_READ(UART_REG_LCRH);
 	t &= ~(UART_LCRH_FEN);
@@ -117,6 +118,7 @@ static void uart_init(void)
 
 	/* enable uart, and disable interrupts */
 	UART_WRITE(UART_REG_CTRL, UART_CTRL_EN);
+#endif
 }
 
 static void uart_putc(int ch)
@@ -125,7 +127,7 @@ static void uart_putc(int ch)
 
 	UART_WRITE(UART_REG_DATA, ch);
 
-	while ((UART_READ(UART_REG_FLAG) & UART_FLAG_TXFF) != 0);
+	while ((UART_READ(UART_REG_FLAG) & UART_FLAG_TXFE) == 0);
 }
 
 /*
@@ -150,7 +152,7 @@ static void intc_init(void)
 static void switch_init(void)
 {
 	/* disable PHYS ports */
-	SWITCH_WRITE(SWITCH_REG_PORT_CONF0, 
+	SWITCH_WRITE(SWITCH_REG_PORT_CONF0,
 	    (SWITCH_PORTS_HW << PORT_CONF0_DP_SHIFT));
 
 	/* disable CPU port */
@@ -159,7 +161,7 @@ static void switch_init(void)
 	/* disable GPIO lines */
 	SWITCH_WRITE(SWITCH_REG_GPIO_CONF0, 0);
 	SWITCH_WRITE(SWITCH_REG_GPIO_CONF2, 0);
-	
+
 	/* disable LED lines */
 	SWITCH_WRITE(SWITCH_REG_PORT0_LED, 0);
 	SWITCH_WRITE(SWITCH_REG_PORT1_LED, 0);
diff --git a/target/linux/adm5120eb-2.6/image/Makefile b/target/linux/adm5120eb-2.6/image/Makefile
index 8088726f91..5772272090 100644
--- a/target/linux/adm5120eb-2.6/image/Makefile
+++ b/target/linux/adm5120eb-2.6/image/Makefile
@@ -69,8 +69,11 @@ define Image/Build/LZMAKernel/ZyXEL
 endef
 
 define Image/Build/Initramfs
+# this line is here intentionally
+ifeq (CONFIG_DEVEL,y)
 	$(call Image/Build/LZMAKernel/ZyXEL,p-334wt,bin)
 	$(call Image/Build/LZMAKernel/ZyXEL,p-335,bin)
+endif
 endef
 
 $(eval $(call BuildImage))