From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 7 Nov 2015 16:22:23 +0000 (+0000)
Subject: kernel: remove kmod-acpi-button package, it is already built into the kernel
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0ed2c1a89f56558c820aac257f69bf3217b2aa78;p=openwrt%2Fstaging%2Fnbd.git

kernel: remove kmod-acpi-button package, it is already built into the kernel

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 47414
---

diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 0539493cbd..539d2707aa 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -173,22 +173,6 @@ endef
 $(eval $(call KernelPackage,input-matrixkmap))
 
 
-define KernelPackage/acpi-button
-  SUBMENU:=$(INPUT_MODULES_MENU)
-  TITLE:=ACPI Button Support
-  DEPENDS:=@(TARGET_x86_generic||TARGET_x86_kvm_guest||TARGET_x86_xen_domu||TARGET_x86_64) +kmod-input-evdev
-  KCONFIG:=CONFIG_ACPI_BUTTON
-  FILES:=$(LINUX_DIR)/drivers/acpi/button.ko
-  AUTOLOAD:=$(call AutoLoad,06,button)
-endef
-
-define KernelPackage/acpi-button/description
- Kernel module for ACPI Button support
-endef
-
-$(eval $(call KernelPackage,acpi-button))
-
-
 define KernelPackage/keyboard-imx
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=IMX keypad support