From: Gabor Juhos <juhosg@openwrt.org>
Date: Thu, 23 Dec 2010 12:42:16 +0000 (+0000)
Subject: ar71xx: add support for TL-WR740N v1
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0f659a13ddecb98e16241cf043a15d6045cab357;p=openwrt%2Fstaging%2Fjow.git

ar71xx: add support for TL-WR740N v1

Same as TL-WR741ND but with different hardware ID and without
detachable antenna.

Signed-off-by: Paul Fertser <fercerpav@gmail.com>

SVN-Revision: 24811
---

diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index a36e1756f6..df3873c034 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -49,6 +49,17 @@ endef
 
 $(eval $(call Profile,TLWR741NDV1))
 
+define Profile/TLWR740NV1
+	NAME:=TP-LINK TL-WR740N v1
+	PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR740NV1/Description
+	Package set optimized for the TP-LINK TL-WR740N v1.
+endef
+
+$(eval $(call Profile,TLWR740NV1))
+
 define Profile/TLWR841NV15
 	NAME:=TP-LINK TL-WR841N v1.5
 	PACKAGES:=kmod-ath9k wpad-mini
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f6dc3b01fd..f1a9362184 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -590,6 +590,10 @@ define Image/Build/Profile/TLWR741NDV1
 	$(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr741nd-v1,board=TL-WR741ND,TL-WR741NDv1)
 endef
 
+define Image/Build/Profile/TLWR740NV1
+	$(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr740n-v1,board=TL-WR741ND,TL-WR740Nv1)
+endef
+
 define Image/Build/Profile/TLWR841NV15
 	$(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr841n-v1.5,board=TL-WR841N-v1.5,TL-WR841Nv1.5)
 endef
@@ -677,6 +681,7 @@ define Image/Build/Profile/Default
 	$(call Image/Build/Profile/TLMR3420V1,$(1))
 	$(call Image/Build/Profile/TLWA901NDV1,$(1))
 	$(call Image/Build/Profile/TLWR741NDV1,$(1))
+	$(call Image/Build/Profile/TLWR740NV1,$(1))
 	$(call Image/Build/Profile/TLWR841NV15,$(1))
 	$(call Image/Build/Profile/TLWR841NDV3,$(1))
 	$(call Image/Build/Profile/TLWR841NDV5,$(1))
diff --git a/tools/firmware-utils/src/mktplinkfw.c b/tools/firmware-utils/src/mktplinkfw.c
index aea7e3595a..73603bf1e9 100644
--- a/tools/firmware-utils/src/mktplinkfw.c
+++ b/tools/firmware-utils/src/mktplinkfw.c
@@ -37,6 +37,7 @@
 #define HWID_TL_MR3420_V1	0x34200001
 #define HWID_TL_WA901ND_V1	0x09010001
 #define HWID_TL_WR741ND_V1	0x07410001
+#define HWID_TL_WR740N_V1	0x07400001
 #define HWID_TL_WR841N_V1_5	0x08410002
 #define HWID_TL_WR841ND_V3	0x08410003
 #define HWID_TL_WR841ND_V5	0x08410005
@@ -150,6 +151,14 @@ static struct board_info boards[] = {
 		.kernel_la	= 0x80060000,
 		.kernel_ep	= 0x80060000,
 		.rootfs_ofs	= 0x140000,
+	}, {
+		.id		= "TL-WR740Nv1",
+		.hw_id		= HWID_TL_WR740N_V1,
+		.hw_rev		= 1,
+		.fw_max_len	= 0x3c0000,
+		.kernel_la	= 0x80060000,
+		.kernel_ep	= 0x80060000,
+		.rootfs_ofs	= 0x140000,
 	}, {
 		.id		= "TL-WR841Nv1.5",
 		.hw_id		= HWID_TL_WR841N_V1_5,