From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 24 Jul 2011 09:16:55 +0000 (+0000)
Subject: default to using gzip with mksquashfs if lzma and xz are unavailable
X-Git-Tag: reboot~16192
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0f93db2de5955527ca020e779dd94988bda2bcfe;p=openwrt%2Fstaging%2Fxback.git

default to using gzip with mksquashfs if lzma and xz are unavailable

SVN-Revision: 27748
---

diff --git a/include/image.mk b/include/image.mk
index c17a2cdace..65d79f4db8 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -42,6 +42,7 @@ ifneq ($(CONFIG_JFFS2_LZMA),y)
   JFFS2OPTS += -x lzma
 endif
 
+SQUASHFSCOMP := gzip
 LZMA_XZ_OPTIONS := -Xpreset 9 -Xe -Xlc 0 -Xlp 2 -Xpb 2
 ifeq ($(CONFIG_SQUASHFS_LZMA),y)
   SQUASHFSCOMP := lzma $(LZMA_XZ_OPTIONS)