From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 19 Jul 2015 14:59:26 +0000 (+0000)
Subject: mkimage: cross compile fix: pass HOST_*FLAGS in to uboot's makefile
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=0fc6755f66c842c2b25768bf954fdf60355c21e0;p=openwrt%2Fstaging%2Fansuel.git

mkimage: cross compile fix: pass HOST_*FLAGS in to uboot's makefile

The HOST_*FLAGS are for compiling programs which will run on the machine that is
running the build.  Setting these flags is frequently required for unusual
cross-compiles.

Signed-off-by: Lawrence D'Anna <larry@elder-gods.org>

SVN-Revision: 46424
---

diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index a65eedfcc6..f73cc56318 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -31,8 +31,8 @@ define Host/Prepare
 endef
 
 define Host/Compile
-	$(MAKE) -C $(HOST_BUILD_DIR) defconfig
-	$(MAKE) -C $(HOST_BUILD_DIR) tools-only
+	$(MAKE) -C $(HOST_BUILD_DIR) defconfig   HOSTCFLAGS="$(HOST_CPPFLAGS) $(HOST_CFLAGS)" HOSTLDFLAGS="$(HOST_LDFLAGS)"
+	$(MAKE) -C $(HOST_BUILD_DIR) tools-only  HOSTCFLAGS="$(HOST_CPPFLAGS) $(HOST_CFLAGS)" HOSTLDFLAGS="$(HOST_LDFLAGS)"
 endef
 
 define Host/Install