From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 8 Feb 2016 18:44:21 +0000 (+0000)
Subject: kernel: enable CONFIG_KALLSYMS_UNCOMPRESSED=y
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=108a499c818b1f9a50686994b4ec50edd95f7b87;p=openwrt%2Fstaging%2Fyousong.git

kernel: enable CONFIG_KALLSYMS_UNCOMPRESSED=y

It was enabled ages ago when it was added.
It still saves about 10k after LZMA, so let's enable it again.

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 48680
---

diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 7c99182a46..4b5de5b488 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -122,7 +122,7 @@ define Kernel/Configure/Default
 	awk '/^(#[[:space:]]+)?CONFIG_KERNEL/{sub("CONFIG_KERNEL_","CONFIG_");print}' $(TOPDIR)/.config >> $(LINUX_DIR)/.config.target
 	echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
 	echo "# CONFIG_KALLSYMS_ALL is not set" >> $(LINUX_DIR)/.config.target
-	echo "# CONFIG_KALLSYMS_UNCOMPRESSED is not set" >> $(LINUX_DIR)/.config.target
+	echo "CONFIG_KALLSYMS_UNCOMPRESSED=y" >> $(LINUX_DIR)/.config.target
 	$(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config $(KERNEL_PATCHVER) > $(LINUX_DIR)/.config.override
 	$(SCRIPT_DIR)/kconfig.pl 'm+' '+' $(LINUX_DIR)/.config.target /dev/null $(LINUX_DIR)/.config.override > $(LINUX_DIR)/.config.set
 	$(call Kernel/SetNoInitramfs)