From: Stijn Tintel <stijn@linux-ipv6.be>
Date: Mon, 25 Sep 2017 20:16:37 +0000 (+0300)
Subject: Revert "toolchain/gdb: update to version 8.0.1"
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=118efdcdba4f41b6da866fa7602b2eb17133c1f9;p=openwrt%2Fstaging%2Fzorun.git

Revert "toolchain/gdb: update to version 8.0.1"

Since version 8.0, gdb requires at least gcc 4.8. Unfortunately some of
the buildbot slaves don't meet this requirement, and fail to build LEDE
after the gdb upgrade. Revert to the previous gdb version for now.

This reverts commit 592abe9ef53f921554d48085d6482d4507b3e142.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
---

diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index abd6d033cc..77e24f4609 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -17,11 +17,11 @@ PKG_HASH:=f47930161e9e99c46ab018dabbf56024739dda29c51f92495eaa0d4d7e3511f6
 GDB_DIR:=binutils-$(PKG_NAME)-$(PKG_VERSION)
 PATCH_DIR:=./patches-arc
 else
-PKG_VERSION:=8.0.1
+PKG_VERSION:=7.12.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=3dbd5f93e36ba2815ad0efab030dcd0c7b211d7b353a40a53f4c02d7d56295e3
+PKG_HASH:=4607680b973d3ec92c30ad029f1b7dbde3876869e6b3a117d8a7e90081113186
 GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
 endif
 
diff --git a/toolchain/gdb/patches/110-no_testsuite.patch b/toolchain/gdb/patches/110-no_testsuite.patch
index e86ba6d0cd..68d1c90359 100644
--- a/toolchain/gdb/patches/110-no_testsuite.patch
+++ b/toolchain/gdb/patches/110-no_testsuite.patch
@@ -1,6 +1,6 @@
 --- a/gdb/configure
 +++ b/gdb/configure
-@@ -869,8 +869,7 @@ MAKEINFOFLAGS
+@@ -874,8 +874,7 @@ MAKEINFOFLAGS
  YACC
  YFLAGS
  XMKMF'
@@ -10,7 +10,7 @@
  multi-ice
  gdbserver'
  
-@@ -6473,7 +6472,7 @@ $as_echo "$with_auto_load_safe_path" >&6
+@@ -5617,7 +5616,7 @@ $as_echo "$with_auto_load_safe_path" >&6
  
  
  
diff --git a/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
index 9ce91a024b..562902c50f 100644
--- a/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
+++ b/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
@@ -1,6 +1,6 @@
 --- a/gdb/gdbserver/configure
 +++ b/gdb/gdbserver/configure
-@@ -2469,7 +2469,7 @@ $as_echo "$as_me: error: \`$ac_var' was 
+@@ -2476,7 +2476,7 @@ $as_echo "$as_me: error: \`$ac_var' was
        ac_cache_corrupted=: ;;
      ,);;
      *)