From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Mon, 1 Nov 2021 13:47:02 +0000 (+0100)
Subject: valgrind: Activate also on MIPS 64
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=11ad15ed89db8dfafa347f5db0c4a370bfb87270;p=openwrt%2Fstaging%2Fxback.git

valgrind: Activate also on MIPS 64

This activates valgrind also on mips64 and mips64el.

This was working fine in a basic test in qemu.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

diff --git a/package/devel/valgrind/Makefile b/package/devel/valgrind/Makefile
index 4f0e0fd493..e6ebff4b30 100644
--- a/package/devel/valgrind/Makefile
+++ b/package/devel/valgrind/Makefile
@@ -33,7 +33,7 @@ include $(INCLUDE_DIR)/kernel.mk
 define Package/valgrind
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:=@mips||mipsel||i386||x86_64||powerpc||arm_v7||aarch64 +libpthread +librt
+  DEPENDS:=@mips||mipsel||mips64||mips64el||i386||x86_64||powerpc||arm_v7||aarch64 +libpthread +librt
   TITLE:=debugging and profiling tools for Linux
   URL:=http://www.valgrind.org
 endef