From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sun, 14 Jul 2013 14:23:04 +0000 (+0000)
Subject: mac80211: b43: load b43 on core rev 17 and 18.
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=13f3c9dbe54dc05d8f23bfcf2f3d846a9dcf8aaf;p=openwrt%2Fstaging%2Fansuel.git

mac80211: b43: load b43 on core rev 17 and 18.

This is now controlled by a module parameter and the default
configuration depends on brcmsmac being installed.
This patch causes b43 to take core rev 17 and 18 always by default.

SVN-Revision: 37307
---

diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 2f7fbbe877..e4fa9252f1 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1221,7 +1221,7 @@ endif
 config-$(call config_package,carl9170) += CARL9170
 
 config-$(call config_package,b43) += B43
-config-y += B43_SSB B43_BCMA B43_BCMA_EXTRA B43_PHY_LP
+config-y += B43_SSB B43_BCMA B43_PHY_LP
 config-$(CONFIG_PACKAGE_B43_PHY_N) += B43_PHY_N
 config-$(CONFIG_PACKAGE_B43_PHY_HT) += B43_PHY_HT
 config-$(CONFIG_PACKAGE_B43_PIO) += B43_PIO
diff --git a/package/kernel/mac80211/patches/847-b43-always-take-overlapping-devs.patch b/package/kernel/mac80211/patches/847-b43-always-take-overlapping-devs.patch
new file mode 100644
index 0000000000..9d1d419460
--- /dev/null
+++ b/package/kernel/mac80211/patches/847-b43-always-take-overlapping-devs.patch
@@ -0,0 +1,11 @@
+--- a/drivers/net/wireless/b43/main.c
++++ b/drivers/net/wireless/b43/main.c
+@@ -118,7 +118,7 @@ static int b43_modparam_pio = 0;
+ module_param_named(pio, b43_modparam_pio, int, 0644);
+ MODULE_PARM_DESC(pio, "Use PIO accesses by default: 0=DMA, 1=PIO");
+ 
+-static int modparam_allhwsupport = !IS_ENABLED(CPTCFG_BRCMSMAC);
++static int modparam_allhwsupport = 1;
+ module_param_named(allhwsupport, modparam_allhwsupport, int, 0444);
+ MODULE_PARM_DESC(allhwsupport, "Enable support for all hardware (even it if overlaps with the brcmsmac driver)");
+