From: Jo-Philipp Wich <jow@openwrt.org>
Date: Sun, 29 Jan 2012 23:34:25 +0000 (+0000)
Subject: rules.mk: filter "." and "./" entries from $PATH, prevents toolchain build issues... 
X-Git-Tag: reboot~15043
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=1504738c02e27bd9c67b37e30524eda34363efae;p=openwrt%2Fstaging%2Fchunkeey.git

rules.mk: filter "." and "./" entries from $PATH, prevents toolchain build issues and likely other problems

SVN-Revision: 29951
---

diff --git a/rules.mk b/rules.mk
index 6c7514f2a7..c6e571115c 100644
--- a/rules.mk
+++ b/rules.mk
@@ -106,7 +106,7 @@ TARGET_DIR:=$(TARGET_ROOTFS_DIR)/root-$(BOARD)
 STAGING_DIR_ROOT:=$(STAGING_DIR)/root-$(BOARD)
 BUILD_LOG_DIR:=$(TOPDIR)/logs
 
-TARGET_PATH:=$(STAGING_DIR_HOST)/bin:$(PATH)
+TARGET_PATH:=$(STAGING_DIR_HOST)/bin:$(subst $(space),:,$(filter-out .,$(filter-out ./,$(subst :,$(space),$(PATH)))))
 TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3)
 TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib