From: Mauri Sandberg <maukka@ext.kapsi.fi>
Date: Sat, 5 Feb 2022 23:07:08 +0000 (+0200)
Subject: kernel: add package kmod-multiplexer
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=15f0074beb55f85ee1de6a34a4c7758f5616f9e1;p=openwrt%2Fstaging%2Flinusw.git

kernel: add package kmod-multiplexer

Adds new kernel module for GPIO controlled multiplexer support.

Signed-off-by: Mauri Sandberg <maukka@ext.kapsi.fi>
Signed-off-by: Petr Štetiar <ynezz@true.cz> [missing commit description]
---

diff --git a/package/kernel/linux/modules/multiplexer.mk b/package/kernel/linux/modules/multiplexer.mk
new file mode 100644
index 0000000000..135fc62c6d
--- /dev/null
+++ b/package/kernel/linux/modules/multiplexer.mk
@@ -0,0 +1,34 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+MENU_TITLE:=Multiplexer Support
+
+define KernelPackage/mux-core
+  SUBMENU:=$(MENU_TITLE)
+  TITLE:=Multiplexer Support
+  KCONFIG:=CONFIG_MULTIPLEXER
+  FILES:=$(LINUX_DIR)/drivers/mux/mux-core.ko
+  AUTOLOAD:=$(call AutoLoad,25,mux-core,1)
+endef
+
+define KernelPackage/mux-core/description
+  Kernel module for multiplexer support
+endef
+
+$(eval $(call KernelPackage,mux-core))
+
+define KernelPackage/mux-gpio
+  SUBMENU:=$(MENU_TITLE)
+  TITLE:=GPIO-controlled Multiplexer controller
+  KCONFIG:=CONFIG_MUX_GPIO
+  DEPENDS:=@GPIO_SUPPORT kmod-mux-core
+  FILES:=$(LINUX_DIR)/drivers/mux/mux-gpio.ko
+  AUTOLOAD:=$(call AutoLoad,25,mux-gpio,1)
+endef
+
+define KernelPackage/mux-gpio/description
+  Kernel modules for GPIO-controlled Multiplexer controller
+endef
+
+$(eval $(call KernelPackage,mux-gpio))